Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать блок-схемы для программы, которая ведёт значение переменной n и посчитает сумму ряда от следущего 1/1 +1/(1*2) ... +

10-11 класс

1/(1*2*3*...n)

айкуи 31 марта 2017 г., 12:03:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Samohleb2012
31 марта 2017 г., 14:28:27 (7 лет назад)

var

  i, j,fact, n:integer;

  summ:real;

begin

  write('n = '); readln(n);

  summ := 0;

  for i := 1 to n do

  begin

    fact := 1;

    for j := 2 to i do

      fact := fact * j;

    Summ := Summ + 1 / fact;

  end;

  writeln('Summ = ', Summ);

end.

 

+ 0 -
прололо
31 марта 2017 г., 16:47:17 (7 лет назад)

var
n,z,i:integer;
s:real;
begin
readln(n);
z:=1;
for i:= 1 to n do begin
z:=z*i;
s:=s+1/z;
end;
writeln(S);
end.

Ответить

Другие вопросы из категории

Очень надо, помогите пожалуйста. Задача по информатике.

Вычислить значение функции Y(x задается с клавиатуры)
Y равен системе: x, при x<-5
|x+2|, -5<x<5
cosx, x>5

Информатика, умоляю, помогите!
Помогите пожалуйста:

Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 100 символов.сколько символов в использованом алфавите,если всё сообщение содержит 1125 байтов.

Читайте также

Дан фрагмент программы. Нарисуйте блок-схему, восстановите вид формулы для расчета S

PASCAL:

VAR
A:ARRAY[1...100]OFF
INTEGER;
N,I,J: INTEGER;
S: REAL;
BTGIN
N:=8;
FOR I:=1 TO N DO
BEGIN
S:=0;
FOR J:=1 TO I DO
S:=S+(A[J]);
S:=ABS(S);
WRITELN(`S`=`,S:9:2);
END;
READLN;
END.

QBASIC
DEFINT N,I,J,S,
DIM A(100) AS INTEGER
N:=8
FOR I=1 TO N
S=0
FOR J=1 TO I
S=S+A[J]
NEXT J
S=ABS(S)
PRINT S
NEXT I

ШКОЛЬНЫЙ АЯ

алг слово(рез вещ s)
цел раб А[1:100]
n:=8
нц для I от 1 до n
s=0
нц для j от 1 до I
s=s+a[j]
кц
s=abs(s)
вывод s
кц
кон

Пожааалуйста нужны блок-схемы для трех вариантов получения s





Нужно написать блок схему для следуйщей программы: Program Example1;

Const n=6;m=4;
Var A:array[1..n,1..m] of integer;
i,j,k:byte;
Begin
For i:=1 to n do
Begin
For j:=1 to m do
Begin
A[i,j]:=random(31)-15;
write(A[i,j]:4);
End;
writeln;
End;
write('Строки в которых один нулевой элемент: ');
For i:=1 to n do
Begin
k:=0;
For j:=1 to m do
if A[i,j]=0 then inc(k);
if k=1 then write(i:2);
End;
readln;
End.

1. Составьте блок-схему и программу вычисления значения функции:

2. Составьте программу, определяющую, является ли данное число делителем числа 3.
3*. Составьте программу, заменяющую из двух данных чисел меньшее число суммой, а большее – произведением этих чисел.



Вы находитесь на странице вопроса "Написать блок-схемы для программы, которая ведёт значение переменной n и посчитает сумму ряда от следущего 1/1 +1/(1*2) ... +", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.