Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Нужно перевести данную программу на язык С++ с паскаля.Срочно! program tt; uses crt; const Nmax=10; var m:array[1..Nmax] of integer; i,i_min,i_max:byte;

5-9 класс

min,max:integer; begin ClrScr; randomize; writeln('Исходный массив:'); for i:=1 to Nmax do begin m[i]:=random(20)-10; write(m[i],' '); end; max:=m[1]; min:=m[1]; i_min:=1; i_max:=1; for i:=1 to Nmax do begin if m[i]>max then begin max:=m[i]; i_max:=i; end; if m[i]

Nizamimamedov 04 окт. 2013 г., 9:23:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kirunchikkozlova
04 окт. 2013 г., 11:32:18 (10 лет назад)

#include <iostream>
#include <stdio.h>
#include <conio.h>
#include <time.h>

using namespace std; //если пишешь в борланде то удали эту строку

const short n = 10;

int main()
{
    srand(unsigned(time(NULL)));
    int a[n];
    short iMax = 0;
    short iMin = 0;
    cout << "Source massive \n";
    for (int i = 0; i < n; i++)
    {
        a[i] = rand() % 21 - 10;
        cout << a[i] << " ";
        if (a[iMax] < a[i])
            iMax = i;
        if (a[iMin] > a[i])
            iMin = i;
    }
    cout << "\nMax a[" << iMax + 1<< "] = " << a[iMax] << "\n";
    cout << "Min a[" << iMin + 1<< "] = " << a[iMin] << "\n";
    _getch(); //если пишешь в борланде замени эту строку на getch();
    return 0;
}

Ответить

Другие вопросы из категории

помогите с кроссвордом

ПОЖАЛУЙСТА СРОЧНО
отвечайте пожалуйста так:
пишите цифру и ответ на вопрос

Автомат получает на вход пятизначное десятичное число. По полученному числу строится новое десятичное число по следующим правилам.

1. Вычисляются два числа – сумма первых трёх цифр и сумма последних трёх цифр.
2. Полученные два числа записываются друг за другом в порядке неубывания (без разделителей).
Определите, сколько из приведённых ниже чисел могут получиться
в результате работы автомата.

Читайте также

. Дан массив, содержащий 2014 положительных целых чисел. Напишите на одном из языков программирования программу, которая находит в этом массиве количество

элементов, значение которых более чем в два раза превосходит значение предшествующего элемента. Например, для массива из 6 элементов, содержащего числа 2, 5, 10, 15, 40, 100, программа должна выдать ответ 3 (условию соответствуют элементы со значениями 5, 40 и 100). Программа должна вывести общее количество подходящих элементов, значения элементов выводить не нужно. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из описанных переменных.
Паскаль Алгоритмический язык
const N = 2014;
var a: array [1..N] of integer;
i, j, k: integer;
begin
for i:=1 to N do
readln(a[i]);

end. алг
нач
цел N=2014
целтаб a[1:N]
цел i, j, k
нц для i от 1 до N
ввод a[i]
кц

кон


Помогите сослать программу на Паскале.Поиск чисел в массиве. Program Example;

{Программа заполняет массив Rand случайными числами в диапазоне от 0 до 50,
вводит число Х, и вычисляет, сколько раз Х входит в массив Rand}

Var Rand: array[1..20] of integer;
I, X, NumberX : integer,
Begin
{Установка датчика случайных чисел}
​Randomize;
{Заполнение массива случайными числами и вывод их на экран}
​Writeln(‘Массив случайных чисел:’)
​For I:=1 to 10 do
​begin
​ Rand[I]:=random(50); Write(Rand[I]:4)
​End;
​Writeln;
{Ввод Х}
​Write(‘Введите Х:’)); Readln(X);
{Подсчет числа вхождений Х в массив}
​NumberX:=0;
​For I:=1 to 10 do
​​If Rand(I)=X then NumberX:=NumberX+1;
{Анализ и вывод результата}
​If NumberX=0
​Then​writeln(‘В массиве нет числа’,X)
​Else writeln(‘Число’,X,’в массиве присутствует’,NumberX,’раза’)
End.

Помогите, пожалуйста, очень срочно

1. Чему будет равняться x после выполнения фрагмента программы:
x:=0;
repeat
x:=x+8
until x>=21.

2. Дано описание массива
var mas: array [-22;0] of integer;
Сколько элементов содержит данный массив?

3.Определите, что делает следующая программа, и какой результат она выдаст на заданном массиве (1,4,0,-1,-4)
Program n1
const n=5
var a: array [1...n] of integer;
i,b: integer;
begin
b:=a[1];
for i:=2 to n do
if a[i] writeln (b);
end.

4. Допустим, имеется одномерный массив, содержащий от 0 до 49 включительно. Требуется исключить из него все элементы, значения которых меньше 15.

Pascal. Написать такую программу:

На вход получает N - количество элементов последовательности чисел.
Затем следуют элементы последовательности.
Программа должна вывести все отрицательные элементы последовательности, чьи квадраты не превосходят 7000, в порядке, обратном порядку их ввода.
Например на вход идут:
4
-3
6
-7
-99

На выходе получаем:
-7
-3

Я предлагаю такое начало программы:

program num9;
const N = 5;
var a : array [1..N] of integer;
i, m : integer;
begin for i := 1 to N do
readln (a[i]);
m := a[i];
if (m < 0) and (m*m < 7000) then

Как следует поступить дальше?

Решить задания на языке программирования в Turbo Pascal: 1) Выполните тестирование программы: опишите как будут меняться значения переменных и

что появится на экране в результате выполнения программы. Для переменной S ввести строку - 'аб2в457где245*ж'

Program z2;

uses crt;

var s:string;

k,sum,i,n:integer;

begin

readln(s);

i:=1;

repeat

val(s[i],n,k);

i:=i+2;

sum:=sum+n;

writeln(n);

until i>length(s);

writeln(sum);

readkey;

end.

2) Дано предложение. Удалить из него все буквы с



Вы находитесь на странице вопроса "Нужно перевести данную программу на язык С++ с паскаля.Срочно! program tt; uses crt; const Nmax=10; var m:array[1..Nmax] of integer; i,i_min,i_max:byte;", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.