Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

СРОООЧНО!Найдите средне арифметическое таблицы[1...10]Спасибо!

5-9 класс

ПАФОСтная 14 февр. 2014 г., 3:16:48 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Шнуфя
14 февр. 2014 г., 5:50:14 (10 лет назад)

program p1;
const n=10;
var a: array [1..n] of integer;
s,i: integer;
r: real;
begin
randomize;
for i:= 1 to n do
begin
a[i]:= random (20)-5;
write (a[i]:3);
s:=s+a[i];
end;
writeln;
r:=s/n;
write ('среднее арифметическое=',r);
end.

+ 0 -
Lilchik1204
14 февр. 2014 г., 7:40:18 (10 лет назад)

Program Jessika;
const
  n=10;
var
  table: array [1..n] of integer;
  sum,i: integer;
  arifm: real;
begin
  randomize;
  sum:=0;
  writeln ('элементы таблицы:');
 for i:= 1 to n do
    begin
      table[i]:= random (101)-50;
      write (table[i]:4);
      sum:=sum+table[i];
    end;
  writeln();
  arifm:=sum/n;
  writeln ('Cреднее арифметическое таблицы равно ',arifm:3:2);
end.

Ответить

Другие вопросы из категории

загадка к телефону
Pascal

Составьте программу построения таблицы
значений функции y=0,5x+8 на интервале от -4 до 4 с шагом 0.5

Читайте также

Проблема с Паскалем. Мне надо посчитать среднее арифметическое всех отрицательных чисел в массиве из десяти элементов. Я понимаю, как сначала надо

распредилить, какие числа меньше нуля, но как вычислить среднее арифметическое, не зная точное кол-во отрицательных элементов? Желательно написать полной программой. Заранее спасибо с:

исло M называется средним арифметическим двух чисел A и B, если M равно (A + B) / 2. Васе на день рождения подарили два числа A и B. Именинник легко

вычислил их среднее арифметическое и так обрадовался, что потерял число B. Помогите Васе восстановить потерянное число.

помогите пожалуйста с free pascal :) 1. вывести на экран следующие числа: 5.8,5.9...6.8. 2.с клавиатуры задаётся цена 1 порции мороженого. вывести на

экран стоимость 1,2,..15 порций мороженого. 3.найдите сумму первых пятидесяти натуральных чисел,кратных 12. 4. с клавиатуры задаётся 10 чисел.найдите произведение чисел,меньших 10.найдите среднее арифметическое чисел кратных 3.

cпасибо огромное!

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке



Вы находитесь на странице вопроса "СРОООЧНО!Найдите средне арифметическое таблицы[1...10]Спасибо!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.