Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

дано трехзначное число. определите входят ли в него цыфра ?

5-9 класс

WindBoom 18 февр. 2017 г., 23:21:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
АлександрТрушкин
19 февр. 2017 г., 0:27:23 (7 лет назад)

var a,b:integer;
begin
write('Введите число ');
readln(a);
write('Введите цифру ');
readln(b);
if (a mod 10 <> b) and (a div 100 <> b) and ((a mod 100) div 10 <> b) then writeln('Цифры нету')
else writeln('Цифра есть');
end.

+ 0 -
87752436701
19 февр. 2017 г., 1:02:27 (7 лет назад)

Пишу на QBasic
CLS
INPUT A
INPUT X
Q= A MOD 10
W=A DIV 100
E=((A MOD 100)-Q)/10
IF Q=X OR W=X OR E=X THEN
PRINT "Входит"
ELSE
PRINT "Не входит"
END IF

Ответить

Другие вопросы из категории

Укажите отношение для пары "процессор и системный блок":

1.Является элементом множества
2.Входит в состав
3.Является разновидностью
4.Является причиной

Информатика "Программирование разветвляющихся алгоритмов" 1. Написать программу, определяющую, является ли

произвольное число X четным.

2. Написать программу, определяющую, является ли целое число T делителем целого числа X.

3. Для произвольного числа A написать программу, возводящую его в квадрат, если число отрицательное, извлекающую из A квадратный корень, если положительное, оставляющее A без изменения, если A=0

Файл размером 80 Кбайт передаётся через некоторое соединение со скоростью 2048 бит в секунду. Определите размер файла (в Кбайт), который можно передать

за то же время через другое соединение со скоростью 768 бит в секунду. В ответе укажите одно число – размер файла в Кбайт.

Читайте также

1.Дано трехзначное число. а)Определите, входят ли в него цифры 4 и 7. б)Определите, входят ли в него одновременно цифры 4 и 7. 2. Даны

четыре целых числа. Вывести на экран минимальное из них.

3.Даны три вещественных числа a, b и с - коэффициенты уравнения ax^2+bx+c. Найдите решение этого уравнения или сообщите, что решения не существует.

Дано трехзначное число. напишите программу, которая определяет:

1) есть ли среди цифр заданного трехзначного числа одинаковые;
Пример входных данных
123 нет
121 да
222 да

2) является ли число '' перевертышем" , т.е. числом , десятичная запись которого читается одинаково слева направо и справа налево.
Пример входных данных
122 нет
121 перевертыш
222 перевертыш

Пожалуйста с примером!!!
Заранее большое спасибо



Вы находитесь на странице вопроса "дано трехзначное число. определите входят ли в него цыфра ?", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.