Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дан набор ненулевых чисел ,признак его завершения число 0 .вывести сумму всех положительных четных чисел из данного набора. если требуемые числа

5-9 класс

отсутсвуют вывести то вывести 0

Katrin145 25 февр. 2014 г., 9:19:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nast2412
25 февр. 2014 г., 11:20:44 (10 лет назад)

var a,s:integer;
begin
a:=-1;
while (a<>0) do begin
read(a);
if a>0 then s+=a;
end;
writeln(s);
end.

Ответить

Другие вопросы из категории

Доброго всем вечера/дня!Пожалуйста,помогите с Информатикой

записать программу в ПАСКАЛЬ(!)
Дано вещественное число — цена 1 кг конфет. Вывести стоимость 1, 2, …, 10 кг конфет.
И если не сложно,то с подробными объяснениями!!!




Всем заранее спасибо!!!)

Читайте также

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.

1. Дано натуральное число n. Определить есть ли в нем цифра x. (x, n - вводятся с клавиатуры)

2. Напишите программу, которая вводит последовательность целых ненулевых чисел, признак окончания ввода - число 0. Выясните есть ли в ней хотя бы одна пара одинаковых "соседних" чисел. СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Самостоятельная работа. 1. Переведите каждое из данных чисел из десятичной системы счисления в двоичную и восьмеричную системы: 45, 123. 2. Переведите

каждое из данных чисел из десятичной системы счисления в восьмеричную и шестнадцатеричную системы: 123, 2012. 3. Переведите в десятичную систему двоичные числа: 101101, 111111.

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

Дана последовательность целых чисел, оканчивающаяся числом 100.

Определить, есть ли в последовательности число 77. Если такое число
есть, то вывести «Yes». В противном случае вывести «No». Решить данную
задачу двумя способами, используя циклы с пред и пост условиями.( в ПАСКАЛЕ)



Вы находитесь на странице вопроса "дан набор ненулевых чисел ,признак его завершения число 0 .вывести сумму всех положительных четных чисел из данного набора. если требуемые числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.