Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:

10-11 класс

1-й равен текущему индексу ; 2-й равен квадрату предыдущего элемента; 3-й равен целой части от деления предыдущего элемента на текущий индекс . 2 Задание : сформируйте массив, содержащий 15 элементов ,с помощью датчику случайных чисел. Получите новый массив,каждый элемент которого равен разности квадрата и самого соответствующего элемента исходного массива. Найдите разность сумм элементов исходного и нового массивов. выведите на экран исходные и полученные результаты.

OPERA24 02 дек. 2016 г., 3:46:29 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Slavnykh
02 дек. 2016 г., 4:22:49 (7 лет назад)

var

  a : array [1..9] integer;

  i : integer;

begin

  for i := 1 to 9 do

    if i mod 3 = 1 then a[i] := i

    else if i mod 3 = 2 then a[i] := sqr (i - 1)

    else a[i] := a[i - 1] div i;

  for i := 1 to 9 do

    write (a[i], ' ');

end.

 

var

  b, a : array [1..15] of integer;

  i, sa, sb : integer;

begin

  randomize;

  sa := 0; sb := 0;

  for i := 1 to 15 do

  begin

    a[i] := trunc (random (100)) + 1;

    write (a[i], ' ');

    sa := sa + a[i];

  end;

  writeln;

  for i := 1 to 15 do

  begin

    b[i] := sqr (a[i]) - a[i]);

    write (b[i], ' ');

    sb := sb + b[i];

  end;

  writeln;

  writeln (abs (sb - sa));

end.

  

Ответить

Другие вопросы из категории

Задача 1.1. Некто задумал натуральное число, не превосходящее 124, а затем сообщил: "Задуманное мною число является кратным числу 3". Какое количество бит

информации содержится в этом сообщении?

Задача 1.2. Задача. Рисунок построен с использованием палитры 256 цветов на экране монитора с графическим разрешением 124 на 124 Рассчитать объем памяти, необходимый для хранения этого рисунка в Кбайтах.

Задача 1.3. Производится двухканальная (стерео) звукозапись с частотой дискретизации 22 кГц и глубиной кодирования 24 бита. Запись длится 124 секунды, ее результаты записываются в файл, сжатие данных не производится. Каков размер полученного файла, выраженному в мегабайтах?

Задача 2.1. Переведите исходное число 124 из десятичной в шестнадцатеричную, а затем в двоичную систему счисления и представьте в прямом обратном и дополнительном кодах. Результаты сведите в таблицу 2.
Таблица 2
А10 А16 А2
В прямом коде В обратном коде В дополнительном коде


Помогите решить уравнение :))

(смотрите приложение)

Написать программу в VBA в Access

Задача: Написать программу, вычисляющую значение функции y, если
y=2a+x2 при x>0
y=3b+3a при x=0
y=sinx+a при x<0

Читайте также

Здравствуйте, помогите, пожалуйста, составить программу. Задача-Сформулируйте и выведите на экран массив из 9 элементов, каждые три последовательных

элемента которого составлены по следующему правилу:
1-й равен квадрату текущего индекса, увеличенному на 5;
2-й равен целой части квадратного корня из предыдущего элемента;
3-й равен целой части от деления двух предыдущих элементов.

сформируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:

1-й равен удвоенному числу, введенному с клавиатуры;
2-й равен квадрату предыдущего индекса;
3-й равен остатку от деления индекса на 2

Помогите решить задачи.

1.Сформулируйте и выведите на экран массив из девяти элементов, каждые три последовательных элемента которого составлены по следующему правилу:
1-й равен случайному двузначному числу;
2-й равен целой части от деления случайного трехзначного числа на его индекс;
3-й равен остатку от деления случайного двузначного числа на 10.
2.

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.



Вы находитесь на странице вопроса "1 Задание:сформируйте и выведите на экран массив из девяти элементов,каждые три последовательных элемента которого составлены по следующему правилу:", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.