Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в

5-9 класс

след за которыми в файле f идёт буква а

Aida9797 10 авг. 2013 г., 17:58:06 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Petinovmax
10 авг. 2013 г., 19:28:48 (10 лет назад)

var f,g:string;

i:integer;

begin

readln(f);

for i:=1 to length(f)-1 do if (f[i+1]='а') then g:=g+f[i];

writeln(g);

g:='';

for i:=2 to length(f) do if (f[i-1]='а') then g:=g+f[i];

writeln(g);

end.

Ответить

Другие вопросы из категории

что такуое SDK плиз аааааааа

Читайте также

Даны три маски файла, однозначноДаны три маски файла, однозначно определяющих имя файла. Известно, что имя этого файла состоит из 10 символов, а

расширение из трех. В ответе укажите имя этого файла. (Например: Spravka.doc)
?*sk*v??*?.j**
m*??**ci*?.**g
*o??o?**ty.*p?

Задача «Справедливое распределение»

У Андрея было А грамм крупы, у Бориса – В
грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну
на троих. Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет
Андрею с Борисом.

Требуется написать программу, которая
определяет, как Андрей и Борис должны

поделить конфеты по справедливости.
Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или
из файла input.txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в
файл output.txt. В единственной

строке необходимо вывести два целых числа
— количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3

Ребятки!!!!ПОмогите пожалуйста очень срочно!!!! Дан файл f компоненты которого действительные числа.Найти сумму компонентов

файла.Результат поместить в файл g.

дан файл f компоненты которого являются целыми числамию Найти наибольший и наименьший из компонентов файла.результат поместить в файл g

ДАн файл f компоненты которого являются целыми числами найти количество чётных чисел среди компонентов.результат поместить в файл g

Дан файл F компоненты которого являяются целыми числами.записать в файл g все чётных числа файла f

Дан файл F компоненты которого являяются целыми числами переписать компоненты файла f в файл g,так чтобы в файле сначала шли отрицательные а потом положительные числа.



Вы находитесь на странице вопроса "Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.