Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

как сделать минимальное число? var

5-9 класс

q,a,z:integer;
t: array [1..10] of integer;
begin
for a:=1 to 10 do
begin
write('введите число ', a);
t[a]:=random(175)+182;
writeln(t[a]:4);
end;
a:=t[1]; z:=1;
for a:=2 to 10 do
begin
if t[a]>q then
begin
q:=t[a];
z:=a;
end;
end;
write('самое большое число под номером',z,'это число',q);
end.

Kristinary 01 сент. 2014 г., 10:59:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Hfdnjfn
01 сент. 2014 г., 13:05:52 (9 лет назад)

var       
q,a,z:integer;
t: array [1..10] of integer;
begin
  for a := 1 to 10 do
  begin
    t[a] := random(175)+182;
    writeln(t[a]:4);
  end;
  q := t[1];
  z := 1;
  for a:= 2 to 10 do
  begin
    if t[a]>q then
    begin
      q := t[a];
      z := a;
    end;
  end;
  write('самое большое число под номером ',z,' это число ',q);
end.



Ответить

Другие вопросы из категории

тяжёлая промышленость - это .
Помогите, пожалуйста!!!!!

Мне очень срочно надо!
Кто знает программу исполнитель "Стрелочка".
Скажите, пожалуйста, что в жизни напоминает стрелочку?

ПОМОГИТЕ ПОЖАЛУЙСТА!! №1

Даны числа a, b, c, составляющие стороны треугольника и числа d,
f, составляющие стороны прямоугольника. Написать программу,
определяющую, площадь какой фигуры больше.
№2
Даны объёмы и массы двух тел из разных материалов. Написать
программу, определяющую плотность какого материала больше.
№4

Пользовать вводит с клавиатуры два числа a и b. Написать
программу, определяющую:
1). является ли число a делителем числа b;
2). является ли число b делителем числа

Читайте также

напишите программу которая в последовательности натуральных чисел определяет минимальное число кратное 3. знаю как написать программу

для максимального числа

var

a:integer;

b:longint;

begin

b:=0;

readln(a);

while (a<>0) do

begin

if ((a mod 3=0) and (a>b)) then

b:=a;

readln(a);

end;

writeln(b);

readln

end.

как для минимального??

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, делящееся нацело на 7 . Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, делящееся нацело на 7.
Количество чисел не превышает 1000. Введеные числа не превышают 30 000.
программа должна вывести одно число - минимальное число, делящееся нацело на 7.
Завтра Гиа помогите!!!

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 4. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 4. Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число – минимальное число, оканчивающееся на 4.

Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, оканчивающееся на 6. Программа получает на вход

количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, оканчивающееся на 6. Количество чисел не превышает 1000. Введенные числа не превышают 30 000. Программа должна вывести одно число минимальное число, оканчивающееся на 6.

Как сделать так что бы программа выводила наименьшее число? var

a, b, c: integer;
d: array [1..10] of integer;
begin
for b := 1 to 10 do
begin
write('Bведите число ', b, ' ');
d[b] := random(100) + 100;
writeln(d[b]:4);
end;
b := d[1];
c := 1;
for b := 2 to 10 do
begin
if d[b]>a then
begin
a := d[b];
c := b;
end;
end;
write('Самое большое число под номером ', c, ' это число ', a);
end.



Вы находитесь на странице вопроса "как сделать минимальное число? var", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.