Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Задача. Год является високосным, если его номер кратен 4,однако из кратных 100 високосными являются лишь кратные 400. Например 1700,1800,1900-не

5-9 класс

високосные, а 2000 високосный. Дано натуральное число n. Определить, является ли високосным год с таким номером? Решить на паскале, уровень 8 класса!

KriLi 18 сент. 2013 г., 10:11:40 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Даша5674
18 сент. 2013 г., 12:03:05 (10 лет назад)

Если н не делится на 4 то не високосный, если делится, то проверяем дальше, если н не делится на 100 то високосный, если же делится. проверяем дальше, если н не делится на 400 то не високосный, если н делится на 4000 то високосный

+ 0 -
Daniilvavilin12
18 сент. 2013 г., 12:44:34 (10 лет назад)

programm LeapYear;
var y: integer;
begin
  readln(y);
  if y/4=int(y/4) then
  begin
    if (y/100=int(y/100))and(y/400<>int(y/400)) then
      writeln('Не високосный') else
      writeln('\Високосный';)
  end
  else writeln('Не високосный')
end;

Ответить

Другие вопросы из категории

Пожалуйста ПОМОГИТЕ!

Составьте программу для решения задач:
1.Найдите произведение квадратных корней N первых натуральных чисел
2.Определить делится ли сумма цифр заданного натурального числа на 7
3.Заменяет в записи натурального числа N цифру 8 на цифру 3

Видеопамять делится на 4 странице .

Разрешающая способность дисплея - 640 x 200
Вычислить объем видеопамяти ,если битовая глубина равна 16 .

Пожалуйста помогите, задачи в Паскале:

1)Заполнить массив случайными числами от -100 до +100
и распечатать на экране только отрицательные числа
2)Дан массив из 20 элементов числа от -50 до +50
а)Каждый элемент больше 10 заменить на его квадратный корень
б)Все элементы с четными номерами заменить на их абсолютную величину(модуль)
в)Ко всем отрицательным элементам прибавить 5 , а к остальным первый элемент массива

флэш-карта имеет объём 512 мбайт рукопись содержит 2000 страниц. На каждой странице 80 строк в каждой строке 100 символов. Каждый символ кодируется 16-ю

битами. Кроме того, рукопись содержит 80 иллюстраций объёмом 5 Мбайт каждая. Поместится ли рукопись на флэш-карту и какой её объём в Мегабайтах?

Читайте также

Требуется определить, является ли данный год високосным. (Напомним, что год является високосным, если его номер кратен 4, но не кратен 100, а также если

он кратен 400.) Примеры Входные данные 2007 Выходные данные NO Входные данные 2000 Выходные данные YES

язык Pascal

Требуется определить, является ли данный год высокосным. (Напомним, что год является высокосным, если его номер кратен 4, но не кратен 100, а также если он кратен 400.)

1. Какие пары объектов не находятся в отношении "объект - модель"? А) компьютер - его фотография; Б) компьютер - его функциональная

схема;

В) компьютер - его процессор;

Г) компьютер - его техническое описание.

2. Информационной моделью, которая имеет иерархическую структуру является ...

А) файловая система компьютера;

Б) расписание уроков;

В) таблица Менделеева;

Г) программа телепередач.

3. Какая модель является статической (описывающей состояние объекта)?

А) формула химического соединения;

Б) формулы равноускоренного движения;

В) формула химической реакции;

Г) второй закон Ньютона.

4. Информационной моделью, которая имеет сетевую структуру является ...

А) файловая система компьютера;

Б) таблица Менделеева;

В) генеалогическое дерево семьи;

Г) модель компьютерной сети Интернет.

5. Информационной (знаковой) моделью является …

А) анатомический муляж;

Б) макет здания;

В) модель корабля;

Г) химическая формула.

6. В информационных моделях разомкнутых систем управления отсутствует ...

А) управляющий объект;

Б) управляемый объект;

В) канал управления;

Г) канал обратной связи.

7. Какие из приведенных ниже определений понятия «модель» верные? Отметить все правильные на ваш взгляд ответы.

А) модель - это некое вспомогательное средство, объект, ко торый в определенной ситуации заменяет другой объект;

Б) модель - это новый объект, который отражает некоторые стороны изучаемого объекта или явления, существенные с точки зрения цели моделирования;

В) модель - это физический или информационный аналог объекта, функционирование которого - по определенным парамет рам - подобно функционированию реального объекта;

Г) модель некоторого объекта - это другой объект (реаль ный, знаковый или воображаемый), отличный от исходного, он обладает существенными для целей моделирования свойствами и в рамках этих целей полностью заменяет исходный объект.

8. Вставьте в предложение наиболее точный термин из предло женного ниже списка.

Если материальная модель объекта - это его физическое подобие, то информационная модель объекта - это его ...

А) описание;

Б) точное воспроизведение;

В) схематичное представление;

Г) преобразование.

9. Какое из утверждений верно?

А) информационные модели одного и того же объекта, пусть даже предназначенные для разных целей, должны быть во многом сходны;

Б) информационные модели одного и того же объекта, предназначенные для разных целей, могут быть совершенно разными.

10. Может ли передаваться информация от человека к человеку и от поколения к поколению без использования моделей?

А) нет, без моделей никогда не обойтись;

Б) да, иногда, например, генетическая информация;

В) да, чаще всего знания передаются без использования ка ких-либо моделей.

11. Верно ли, что моделирование представляет собой один из основных методов познания, способ существования знаний?

А) нет; Б) да.

12. Какие из приведенных ниже моделей являются вероятност ными? Выбрать три правильных ответа.

А) прогноз погоды;

Б) отчет о деятельности предприятия;

В) схема функционирования устройства;

Г) научная гипотеза;

Д) оглавление книги;

Е) план мероприятий, посвященных Дню Победы.

13. Правильно ли определен вид следующей модели: «Компью терная модель полета мяча, брошенного вертикально вверх, - динамическая формализованная модель, имитирующая поведение данного объекта»?

А) нет; Б) да.

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!

Билеты на аттракцион имеют номера из четырёх цифр от 0000 до 9999. Назовём билет «счастливым», если сумма первых двух цифр его номера равна сумме

последних двух цифр.
Сколько будет «счастливых» среди всех билетов с четырёхзначными номерами?
Как вы это получили?



Вы находитесь на странице вопроса "Задача. Год является високосным, если его номер кратен 4,однако из кратных 100 високосными являются лишь кратные 400. Например 1700,1800,1900-не", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.