Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

А[3;3] найти количество отрицательных сумм элементов каждой строки

10-11 класс

Prichvina 18 окт. 2016 г., 2:50:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tiger005
18 окт. 2016 г., 5:12:35 (7 лет назад)

const
  n = 3;

var
  a: array[1..n, 1..n] of integer;
  i, j, k, s: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  k := 0;
  for i := 1 to n do
  begin
    s := 0;
    for j := 1 to n do
    begin
      a[i, j] := Random(101) - 50;
      Write(a[i, j]:4);
      s := s + a[i, j]
    end;
    Writeln;
    if s <= 0 then k := k + 1
  end;
  Writeln('Количество строк, суммы элементов которых отрицательны: ', k)
end.

Тестовое решение:
Исходный массив
 -18  28   0
 -48  17  -8
   2   8 -45
Количество строк, суммы элементов которых отрицательны: 2


+ 0 -
Jeena99
18 окт. 2016 г., 6:37:02 (7 лет назад)

А если Вам дадут задание на Луну слетать, Вы тоже пытаться будете? Или все же попробуете догадаться, что речь шла не о Вас, а о том, как Вы это себе представляете?

+ 0 -
Aleksa1999myname
18 окт. 2016 г., 7:12:52 (7 лет назад)

скажи, что не поняла задание. оно немного неоднозначное. и пусть тебе приведет пример ввода и вывода.

+ 0 -
Nsyatchikhina
18 окт. 2016 г., 8:22:26 (7 лет назад)

А чтобы не с пустыми руками идти, я напишу программу, скажете: "Я поняла Ваше задание так..."

+ 0 -
Dartdw
18 окт. 2016 г., 10:13:41 (7 лет назад)

спасибо вам за помощь! реально трудно с этим, но я постараюсь следовать вашему совету, буду разбираться с алгоритмом

+ 0 -
Nataevdokimova
18 окт. 2016 г., 11:49:01 (7 лет назад)

Это совет профессионального программиста, а там - как хотите.

Ответить

Другие вопросы из категории

Составить и реализовать на языке программирования алгоритм с использованием оператора цикла While. Вычислить сумму S=2/3+3/4+4/5+…n-1/n (значение

переменной n вводится с клавиатуры).
Рекомендуемый вид экрана:

Введите значение n:

Дан массив A размера N. Сформировать новый массив B того же размера по следующему правилу: элемент BK равен сумме элементов массива A с номерами от 0 до

K.Не допускается использование операторов, прерывающих ход программы (break,

Помогите пожалуйста, почему в паскале не могу назвать программу?

Пишет Встречено 'Program_house', а ожидался раздел описаний или begin

автоматическое устройство осуществило перекодировку информационного сообщения на русском языке первоначально записанногр в 16 битном коде unicode в 8

битную кодировку кои-8.При этом информационное сообщение уменшилось на 608 бит.Какова длина сообщения в символах?

Читайте также

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

Решать задачу нужно на древнем ТП7 (Турбо паскаль).

Вычислить сумму элементов каждой строки, вводимого С КЛАВИАТУРЫ ДВУМЕРНОГО массива. Обязательно с клавиатуры. Напишите программу пожалуйста.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.



Вы находитесь на странице вопроса "А[3;3] найти количество отрицательных сумм элементов каждой строки", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.