Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Помогите, пожалуйста, это зачётная работа, а я не могу разобраться в ней(

10-11 класс

Написать программу на языке Паскаль, используя цикл WHILE
Вводить с клавиатуры любые числа до тех пор, пока не будет введено любое целое число. Сколько чисел было введено всего и сколько из них было меньше 2?
Посчитать, вывести на экран с пояснением.

Animenew 17 февр. 2017 г., 13:14:21 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Roma21dirol
17 февр. 2017 г., 14:34:08 (7 лет назад)

var a, k, k2:real;
begin
   k:=0;
   k2:=-1;
   a:=0.1;
   while round(a)<>a do begin
       k:=k+1;
       if a>2 then k2:=k2+1;
       readln(a);
       end;
   if (round(a)=a) and (a>2) then k2:=k2+1;
   writeln('Количество: ', k);
   writeln('Количество меньше двух:', k2);
end.

+ 0 -
няшООО
17 февр. 2017 г., 16:06:38 (7 лет назад)

вот попробуй на основе этого uses crt;
var a,k,s,p:integer;
begin
clrscr;
writeln('Вводите числа, пока не будут введены два числа=1:');
k:=0;s:=0;p:=0;
repeat
readln(a);
k:=k+1;
s:=s+a;
if a=1 then p:=p+1;
until p=2;
write('Количество=',k,' среднее=',s/k:0:2);
readln
end.

+ 0 -
Leymanakim
17 февр. 2017 г., 18:33:28 (7 лет назад)

это пример из него можно построить нужную тебе программу

Ответить

Другие вопросы из категории

Читайте также

Помогите пожалуйста.

Требуется написать Блокнот на делфи.
Написал всё, кроме кнопки "Сохранить" не пойму как сделать так, что бы при нажатии она работала как и в блакноте обычном.
Помогите пожалуйста :)

ПОМОГИТЕ, ПОЖАЛУЙСТА, ПРОСТО РАЗЪЯСНИВ ЗАДАНИЕ. ПЖЛ)))

.................................................................................................................................
Возьмите прайс лист любого компьютерного магазина или скачайте в интернете;
Составьте конфигурацию компьютера для специалиста вашей профессии;
Подберите программное обеспечение, поясните, для каких целей будут служить данные программы;
Посчитайте общую стоимость данной конфигурации по прайс листу
....................................................................................................................................
Учусь я на бухгалтера-экономиста.
Давайте думать вместе) Допустим, "специалист вашей профессии" - это бухгалтер. Я беру прайс лист (т.е. лист, где написаны наименования и цены всех товаров). Что такое конфигурация? Как её составить по этому прайс листу, если там и так всего цена и наименования известны...?)))) ПО подобрать, допустим, это будет ;MS Office Excel; для создания таблиц, а для данной задачи для подсчёта общей стоимости конфигурации; и ;MS Office World; для писания отчётов. Что же такое эти "конфигурации"?)))
Помогите, пожалуйста) не пропускайте вопрос)

Помогите, пожалуйста, разобраться и составить верный алгоритм. В задаче требовалось написать программу на Паскале и сравнить её с приведенной в учебнике.

"Подсчитайте кол-во операций в приведенном алгоритме (Ответ приведите в виде функции от параметра n)." Подсчитать кол-во операций самому - это возможно, а как привести ответ в виде функции от параметра n - я не знаю. Помогите, пожалуйста, понять это задание. Заранее благодарен!

Помогите, пожалуйста, составить алгоритм для следующей задачи: Вводятся четыре числа. Известно, что 3 из них равны, а 4-ое отличается от 3-ех других.

Нужно выдать число, которое отличается от других равных, при этом, используя ровно две операции сравнения. Я пытался решить эту задачу и через максимум-минимум, и через условия, но везде натыкался на грабли. Помогите, пожалуйста, разобраться. Заранее благодарю! Перед выставлением решения, рассмотрите следующие варианты: "2 4 4 4", "2 3 2 2 ", "-3 -3 -2 -3", "-4 -4 -4 -5".

Помогите пожалуйста,очень надо,а как сделать не знаю!!!!!

Рассчитать урожайность соломки льна ( Z ), если она зависит от дозы внесенных удобрений ( X ) и количества осадков ( Y ) следующим образом:
при дозе внесенных удобрений Х не более 3 ц/га и количестве осадков У не более 80 мм урожайность составляет
Z = 8+1,5•X+0,1•Y;
при дозе внесенных удобрений Х более 7 ц/га и количестве осадков У более 100 мм урожайность составляет
Z = 7,5+2 X-0,2•Y;
в остальных случаях урожайность составляет:
Z = 11+2,5•X+0,2•Y.
Расчеты выполнить для расчетных данных приведенных в нижеследующей таблице

По результатам расчетов построить графическое изображение.В расчетах использовать функции категория Логические : ЕСЛИ( ), И( ).˂



Вы находитесь на странице вопроса "Помогите, пожалуйста, это зачётная работа, а я не могу разобраться в ней(", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.