Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ЛЮДИ ПОМОГИТЕ!!!

5-9 класс

Дано натуральное число. Выяснить является ли оно простым. Паскаль
Если можно с пояснениями пожалуйста

неавев 04 нояб. 2013 г., 16:37:35 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dsozykina
04 нояб. 2013 г., 17:16:41 (10 лет назад)

var
   x,i,f:integer;
begin
f:=1; //признак, определяющий простоту числа
write('Введите число: ');
readln(x);
for i:=2 to x-1 do //перебираем числа
  if x mod i=0 then f:=0; //если число делится без остатки, значит оно непростое
if f=1 then
   writeln('Это простое число')
   else writeln('Это непростое число')
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ!

Определите, имеет ли решение уравнение 990(x): 60(x) = 1110(3), где x – неизвестное основание системы счисления, и если да, то укажите значение x в качестве ответа.

вопрос 7

помогите!!!!!!!!!

Читайте также

Добрые люди,помогите пожалуйста;)

Заменить цифры от 1 до 10 словами. Например: 1 - "один" и т.д.Помогите составить программу и блок-схему.

для чего необходимо знать правила техники безопаности

люди помогите срочно надо



Вы находитесь на странице вопроса "ЛЮДИ ПОМОГИТЕ!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.