Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОМОГИТЕ ПОЖАЛУЙСТА СОСТАВИТЬ ПРОГРАММУ.ЗАРАНЕЕ СПАСИБО! дано натуральное число n.найти произведение нечетных цифр числа. верно ли, что произведение числа

5-9 класс

является трехзначным числом.

Gazizaalpamys 05 апр. 2017 г., 10:36:59 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
SEugene12z
05 апр. 2017 г., 13:18:16 (7 лет назад)

program msd;
uses crt;
var a,l,proiz,b,i:LONGINT;
begin
clrscr;
readln(a);
proiz:=1;
while true do
begin
l:=a mod 10;
a:= a div 10;
if odd(l) = true then
proiz:=proiz*l
else
b:=b+1;
i:=i+1;
if a = 0 then break;
end;
if b = i then writeln('0')
else
writeln(proiz);
if (proiz>99) and (proiz<1000) then writeln('Da')
else writeln('Net');
ReADKeY;
eND.

Ответить

Другие вопросы из категории

11.К какому ПО относится операционная система? 12. Какие сведения должна иметь операционная система для организации доступа к файлам? 13.Где

хранится выполняемая в данный момент программа и обрабатываемые данные? 14.Что называется каталогом? 15.Когда осуществляется начальная загрузка операционной системы? 16.Что такое операционная система? 17.Как обозначается имя логического диска? 18.Какой каталог называют корневым? 19.Как называется состояние операционной системы, при котором она перестает выдавать результаты и реагировать на запросы? 20.Что происходит с файлами ОС в процессе ее загрузки?

21.Пользователь, перемещаясь из одного каталога в другой, последовательно посетил каталоги LESSONS, CLASS, SCHOOL, D:\ , MYDOC, LETTERS. При каждом перемещении пользователь либо спускался в каталог на уровень ниже, либо поднимался на уровень выше. Каково полное имя каталога, из которого начал перемещение пользователь?

1) D:\MYDOC\LETTERS

2) D:\SCHOOL\CLASS\LESSONS

3) D:\LESSONS\CLASS\SCHOOL

4) D:\LESSONS

22. Определите, какое из указанных имен файлов не удовлетворяет маске: ?*di.t?*

1) poydi.t

2) pogudi.tanx

3) 2di.t9

4) melodi.theme

23.В некотором каталоге хранится файл Список_литературы.txt. В этом каталоге создали подкаталог с именем 10_CLASS и переместили в него файл Список_литературы.txt. После чего полное имя файла стало D:\SCHOOL\PHYSICS\10_CLASS\Список_литературы.txt.

Каково пол­ное имя каталога, в котором хранился файл до перемещения?

1) D:\SCHOOL\PHYSICS\10_CLASS

2) D:\SCHOOL\PHYSICS

3) D:\SCHOOL

4) SCHOOL

24. Какой из файлов соответствуют маске ??P*.A??:

1) ppepsi.abc;

2) pedgy.arj;

3) pepper.arj;

4) pepsi.a1;

5) fanta.doc

Статья, набранная на компьютере, содержит 19 страниц. На каждой странице – 50 строк, в каждой строке – 64 символа (включая пробелы между словами). Каждый

сим-вол кодируется 16 битами. Определите информационный объем статьи (в Мбайтах) в этом варианте представления.

Читайте также

Помогите, пожалуйста, написать программу на Паскале.

Дана строка. Верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.



Вы находитесь на странице вопроса "ПОМОГИТЕ ПОЖАЛУЙСТА СОСТАВИТЬ ПРОГРАММУ.ЗАРАНЕЕ СПАСИБО! дано натуральное число n.найти произведение нечетных цифр числа. верно ли, что произведение числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.