Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Задача на С++, вот код с ошибками

10-11 класс

([C++ Error] Unit1.cpp(25): E2141 Declaration syntax error
[C++ Error] Unit1.cpp(44): E2139 Declaration missing ;
[C++ Error] Unit1.cpp(44): E2134 Compound statement missing })

//---------------------------------------------------------------------------
# pragma hdrstop
# include
# include
# include
# include
//---------------------------------------------------------------------------

void vvod(float z[10], int n);
float Sa (float z[10], int n, float x) ;

//---------------------------------------------------------------------------

void main()
{float a[10], b[10], c[10], h, t, sa, sb,sc;
int i, na, nb, nc;
vvod(a,na);vvod(b,nb);vvod(c,nc);
sa=Sa(a,na,h);
sb=Sa(b,nb,h);
if (sa>sb) cout<<"A i B ikvivalentny" ;
else {sc=Sa(c,nc,t);cout<<"srednee arifmet massiva C ="<< sc;}

//---------------------------------------------------------------------------
void vvod ( float z[10], int & n)
{int i; cin>>n;
for (i=0, i<=n-1,i++)
cin>> z[i];}


//---------------------------------------------------------------------------

float Sa (float z[10], int n, float x)
{int i, k; float s;
k=0; s=0;
for (i=0, i<=i-1,i++)
if (pow(z[i],2)>x) {s=s+z[i]; k++;}
if (k>0)s=s/k;
else cout <<"ochibka ";
return s;}


//---------------------------------------------------------------------------

Lizok2331 21 сент. 2014 г., 7:08:16 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dianagartvix12
21 сент. 2014 г., 8:59:42 (9 лет назад)

#include <iostream>
#include <cmath>
using namespace std;

void vvod(float z[10], int &n);
float Sa (float z[10], int n, float x) ;

//---------------------------------------------------------------------------

int main()
{float a[10], b[10], c[10], h, t, sa, sb,sc;
int i, na, nb, nc;
vvod(a,na);vvod(b,nb);vvod(c,nc);
sa=Sa(a,na,h);
sb=Sa(b,nb,h);
if (sa>sb) cout<<"A i B ikvivalentny" ;
else {sc=Sa(c,nc,t);cout<<"srednee arifmet massiva C ="<< sc;}
}

//---------------------------------------------------------------------------
void vvod ( float z[10], int & n)
{int i; cin>>n;
for (i=0; i<=n-1;i++)
cin>> z[i];
}


//---------------------------------------------------------------------------

float Sa (float z[10], int n, float x)
{int i, k; float s;
k=0; s=0;
for (i=0; i<=i-1;i++)
if (pow(z[i],2)>x) {s=s+z[i]; k++;}
if (k>0)s=s/k;
else cout <<"ochibka ";
return s;}


//---------------------------------------------------------------------------

Ответить

Другие вопросы из категории

В первый день лыжник пробежал 6 км.каждый следующий день он увеличивал пробег на 500 м.какую дистанцию он преодолел на 14 день?каков суммарный пробег

лыжника за эти 2 недели? Помогите пожалуйста,нужно составить программу в QBasic

У исполнителя Удвоитель две команды, которые присвоены номера:

1. прибавь 1,
2. Умножь на 2.

Первая из них увеличивает число на экране на 1, вторая удваивает его.
Программа для Удвоителя - это последовательность команд.
Сколько есть программ, которые число 1 преобразуют в число 23?

Не нужен перебор, есть еще вроде метод решения!

Пожалуйста, подробное решение. Ответ я знаю, нужно только ПОДРОБНОЕ РЕШЕНИЕ.



Спасибо!

Читайте также

Написала код алгоритма в Visual Basic, который правильно считает элементы массива А, В, С и почему то не правильно считает Z по формуле с этими найденными

числами. В чём ошибка? вот код:
Private Sub Command1_Click()

' Описание переменных
Dim N As Single
Dim M(15) As Single
Dim A As Single
Dim B As Single
Dim C As Single
Dim Z As Single
' Описание переменных
' Вод исходных данных
N = 0
M(I) = 0
A = 1
B = 0
C = 0
' Ввод исходных данных

' Реализация алгоритма
For I = 1 To 15
N = Int(Text1.Text)
M(I) = Val(InputBox("Ввести элементы"))
Print Str(M(I))
Next I
For I = 1 To 15
If M(I) > 0 And M(I) <> 0 Then
A = A * M(I)
End If
Next I
For I = 15 To 0 Step -1
If I Mod 2 = 0 Then
If M(I) > 0 Then
B = M(I)
I = 0
End If
End If
Next I
For I = 1 To N Step 1
S = S + M(I)
Next I
C = S / N
Z = С + (А + В/ А * В + 1)
' Реализация алгоритма

' Вывод результата
Text2.Text = Str(A)
Text3.Text = Str(B)
Text4.Text = Str(C)
Text5.Text = Str(Z)
' Вывод результата
End Sub

Прошу переделать код программы с языка Паскаль на С++.

Вот код Паскаль:
var
f:array[1..500] of record
fam:string;
bal:boolean;
end;
buf:boolean;
str:string;

Отдаю все баллы. У меня паника. Нужно максимум через 3 часа. Помогите решить задачи на pascal abc.

а первом фото 4 с процедурой, 8 с функцией.

На втором фото 8 с рекурсивной процедурой.

Помогите решить задачу на паскале, очень нужно:

Дана строка, удалить текст находящийся в скобках (вместе со скобками)

Я тут начал делать, вот только с удалением у меня ничего не получается, напишите как можно сделать

Вот как я делал:
program zd;
uses crt;
var s:string; i,l,n,t,y:integer;
begin
clrscr;
writeln('Введите строку');
readln(s);
l:=length(s);
for i:=1 to n do begin
if s[i]='(' then
t:=i; {здесь присваивал номер найденной скобки}
if s[i]=')' then
y:=i; {так же, как и выше}
delete (s,t,i); {у меня получается, что он удаляет с открывающей скобки и всё что находится вправо, а левая часть до скобки остается нетронутой}
end;
writeln('Данный результат =', s);
readln;
end.



Вы находитесь на странице вопроса "Задача на С++, вот код с ошибками", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.