Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Введите с клавиатуры числа c и m. Если меньшим из них является c, но его значение положительно, найдите и выведите на экран среднее арифметическое

5-9 класс

значений этих чисел. Иначе, найдите и выведите сумму c и m.

Aikosha021 23 окт. 2014 г., 10:22:07 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Bcftd
23 окт. 2014 г., 12:01:18 (9 лет назад)

Program A3;varb,c,i,m:integer;a:real;beginwriteln('Vvedi C');readln(c);writeln('Vvedi M');readln(m);if c<m then if c>0 then begin a:=(c+m)/2;  writeln('srednee arifmet = ',a); end;if c>m then writeln('summa = ',c+m);end.

+ 0 -
25kamilla06
23 окт. 2014 г., 13:42:11 (9 лет назад)

Program A3;
var
b,c,i,m:integer;
a:real;
begin
writeln('Vvedi C');
readln(c);
writeln('Vvedi M');
readln(m);
if c<m then if c>0 then begin a:=(c+m)/2; writeln('srednee arifmet = ',a); end;
if c>m then writeln('summa = ',c+m);
end.

+ 0 -
Kamaloff090
23 окт. 2014 г., 14:15:26 (9 лет назад)

Если помог нажми "Спасибо"

+ 0 -
настя200186
23 окт. 2014 г., 16:05:36 (9 лет назад)

Вообщем алгоритм: мы вводим С и М, если С меньше М и С больше нуля то находим среднее арифмет. если С больше М то находим сумму

Ответить

Другие вопросы из категории

Напишите пожалуйста, что в каком году было.

Заранее спасибо

Как

можно зафиксировать свое авторское
право на
программный
продукт?

Читайте также

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);

Напишите следующую программу. Введите с клавиатуры целое число N. Выведите на экран числа от 1 до N так, чтобы каждое число выводилось столько раз, каково

его значение. Например, если с клавиатуры введено 6, то на экране мы должны увидеть: 1 2 2 3 3 3 4 4 4 4 5 5 5 5 5 6 6 6 6 6 6
Написать программу нужно как можно проще в программе PascalABC

1) составьте программу заполнения элементов массива [1..10 ] случайнымии целыми числами на отрезке [ 0;35 ] и вывода на экран нечетных элементов и

кратных числу 3.

2) составьте программу , которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 100 и выводит на экран среднее арифмитическое элементов массива

Заполните случайными числами в диапазоне от 1 до 5 два массива: A[1:20] и B[1:20]. Найдите и выведите на экран только те элементы этих массивов,

значения которых совпадают. Например, если A[2]=B[2]=4, то на экран надо вывести: Номер: 2 значение: 4 Если совпадений нет, то вывести сообщение об этом. Заранее Спасибо.



Вы находитесь на странице вопроса "Введите с клавиатуры числа c и m. Если меньшим из них является c, но его значение положительно, найдите и выведите на экран среднее арифметическое", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.