Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Задайте массив из 10 элементов с помощью генератора случайных чисел и поменяйте из знак всем нечетным элементам массива на противоположный. Выведите на

10-11 класс

экран исходный и измененный массив. (в паскале)

Amaliy 05 дек. 2016 г., 21:23:56 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vikaaaaaaaaaaayo
06 дек. 2016 г., 0:17:16 (7 лет назад)

var a:array[1..10] of integer;
i:integer;
begin
for i:=1 to 10 do begin
a[i]:=random(-20,20);
write(a[i],' ');
end;
writeln;
for i:=1 to 10 do
if a[i]<0 then write(-1*a[i],' ')
else write(a[i],' ');
end.

Ответить

Другие вопросы из категории

Определите, какое из указанных имен файлов удовлетворяет маске ?ki*.m*

а) kino.rm
б) rkino.mkv
в) kino.mp3
г) kino.m4v

паскаль

Найти двузначные числа
такие, что произведение каждого такого числа и числа с теми же цифрами,
записанными в обратном порядке, есть полный квадрат. Использовать вложенные
циклы

Читайте также

1. Задайте массив из 10 элементов с помощью датчика случайных чисел. Найдите среднее арифметическое нечетных элементов массива с нечетными

индексами. выведите на экран исходный массив и полученное среднее арифметическое.
2. Задайте массив из 10 элементов с помощью датчика случайных чисел. замените все элементы с четными индексами максимальными. Выведите на экран исходный и измененный массивы

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел

1. Задайте массив из 10 элементов с помощью датчика целых случайных чисел. Найдите сумму четных элементов массива. Выведите на экран исходный массив и

полученную сумму.
2. Дан массив В(n). Определите произведение элементов, кратных 3. Выведите на экран исходный массив и найденное произведение.

1)заполнить массив из 15 элементов числами из интервала от -10 до 10 вывести в строчку и повторно вывести в строчку,заменив все четные элементы на число

100.
2) Заполнить массив целыми положительными и отрицательными числами из интервала [-10;10] и вывести его в строчку. Поменять знаки элементов массива на противоположные и повторно вывести массив на экран в строчку.
Пожалуйста,помогите,очень срочно!!!



Вы находитесь на странице вопроса "Задайте массив из 10 элементов с помощью генератора случайных чисел и поменяйте из знак всем нечетным элементам массива на противоположный. Выведите на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.