Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

люди пожалуйста помогите. очень нун . решить задачу в паскале ( удалить все "," из строки и подсчитать количество символов "F", стоящих после "+", и

5-9 класс

количество символов "F", стоящих после "-" (отдельно)

Anytka0022 16 дек. 2016 г., 14:50:25 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
новичек1
16 дек. 2016 г., 17:18:26 (7 лет назад)

Вот после '+'

 

Program Pr1;
uses crt;
var stroka:string;
i,b:integer;
Begin
clrscr;
b:=0;
writeln('Vvedite Stroku');
readln(stroka);
i:=1;
for i:=1 to length(stroka) do if stroka[i]=',' then delete(stroka,i,1);
writeln(stroka);
for i:=1 to length(stroka) do if stroka[i]='+' then begin
delete(stroka,i,1);
break;
end;
for i:=1 to length(stroka) do if stroka[i]='F' then b:=b+1;
writeln('Posle + ',b);
end.

 

 

Вот отдельно после "-" 

 

 

 

 

Program Pr1;
uses crt;
var stroka:string;
i,b:integer;
Begin
clrscr;
b:=0;
writeln('Vvedite Stroku');
readln(stroka);
i:=1;
for i:=1 to length(stroka) do if stroka[i]=',' then delete(stroka,i,1);
writeln(stroka);
for i:=1 to length(stroka) do if stroka[i]='-' then begin
delete(stroka,i,1);
break;
end;
for i:=1 to length(stroka) do if stroka[i]='F' then b:=b+1;
writeln('Posle - ',b);
end.

 

 

 

Ответить

Другие вопросы из категории

Пожалуйста помогите!! Нужно написать программу на языке с ++.

Задание: ввести целое число и найти сумму его цифр, например: Введите целое число: 1234. Сумма цифр числа 1234 равна 10.
Помогите!

Можно ли следующе объекты считать информационными моделями:

• расписание уроков;

Читайте также

РебяТ помогите очень надо, решит не могу не был на уроках, а она мне дала задачу.

Массив содержит 20 случайных чисел из промежутка [1..37] Выводит на экран эдементы больше 11, но меньше 22 ПОжалуйста помогите)

Пожалуйста, помогите) Очень важно) Решите хотя бы одну задачу... А если не сложно, то лучше 2 :))) 1) Информационная ёмкость

человеческой яйцеклетки приблизительно равна 2 в 33 степени битов. Сколько дискет ёмкостью 1,4 МБайт потребуется для размещения этой информации ?

2) Дискета объёмом 1440 КБайт весит 20 г. Сколько будет весить набор дискет, необходимый для полногокопирования информации с жёсткого диска объёмом 80 ГБайт ?

Заранее огроооомное спасибо :)

Пожалуйста помогите по информатике

1) исключи лишнее:
а)микрофон, б)колонки, в) наушники , г) монитор
2)исключи лишнее:
а)процессор, б) монитор, в)клавиатура, мышь
3)установите соответствие. Устройство ПК:
1. клавиатура
2. модем
3.центральный процессор
назначение устройств:
а)передача цифровой информации через каналы связи
б)хранение информации
в)обеспечение общего управления ПК, осуществление вычислений по программе, хранящейся в оперативной памяти
г)визуальное отображение информации, находящейся в оперативной памяти
д)ввод алфавитно-цифровых символов
6.Раздели на группы и дай название каждой группе:
а)принтер,б)сканер,г)мышь,д)проектор,е)веб камера,ж)процессор,з)колонки,и)микрофон, к) монитор
Пожалуйста помогите очень срочно.

Пожалуйста,помогите решить задачу по информатике:

Маша набирает текст со скоростью 40 символов в минуту,а Катя- 20 символов в минуту.Через какое время девочки введут одинаковое количество символов,если Катя начала набирать текст на 5 минут раньше?
Нужно решить без x! Спасибо

Пожалуйста, помогите!!!!!!!!!! Известно, что в 12-летнем цикле года носят вои названия: мышь, корова, тигр, заяц, улитка, змея, лошадь, овца,

обезьяна, курица, собака и свинья. Зная, что 1984 год был годом мыши, написать программу, выводящую номер года и его название.

Учитель сказал, что это решается через кейс..Только как.ПОЖАЛУЙСТА, ПОМОГИТЕ!!!!!!!!!!



Вы находитесь на странице вопроса "люди пожалуйста помогите. очень нун . решить задачу в паскале ( удалить все "," из строки и подсчитать количество символов "F", стоящих после "+", и", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.