Статистика
Всего в нашей базе более 4 327 660 вопросов и 6 445 973 ответов!

Написать программу, которая решает уравнение ax+b <0 относительно x для любых чисел a и b , введёных с клавиатуры.

10-11 класс

Помогите пожалуйста)

Sadykov9991 27 марта 2017 г., 4:50:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
380985603851a54
27 марта 2017 г., 6:25:31 (7 лет назад)

ax + b < 0
ax < -b
x < - b / a

a, b могут быть дробными числами.
Язык программирования: Паскаль

var
a, b : real;
begin
readln (a);
readln (b);
if a <> 0 then
writeln ('x < ', - b / a);
if (a = 0) and (b < 0) then
writeln ('x - любое число');
if (a = 0) and (b >= 0) then
writeln ('нет решений')
end.

+ 0 -
QntalRed1
27 марта 2017 г., 8:00:01 (7 лет назад)

var

  a,b,x:real;

begin

  write ('A = ');readln(a);

  write ('B = ');readln(b);

  if (a=0) and (b>=0) then writeln ('Нет решений') else

    if (a=0) and (b<0) then writeln ('X - любое число') else

      if a>0 then writeln ('X < ',-b/a:0:4) else

        if a<0 then write ('X > ',-b/a:0:4);

  readln;

end.

Ответить

Другие вопросы из категории

написать программу в Паскале:

Даны три числа А,В,С.Определить являются ли они последовательными членами арифметической прогрессии. Найти их разность.

Решить задачу на языке программирования Pascal:

Дано предложение в котором между словами 2 или несколько пробелов:"Мама моет Машу".
Сколько сочетаний букв "Ma" в предложении.

Помогите пожалуйста с решением!

Читайте также

1)Написать программу, которая спрашивает имя пользователя, а потом здоровается. 2)Написать программу, которая выводит на экран перевёрнутый

текст.

3)Написать программу, которая определяет является ли слово палиндромом.

4)Написать программу, определяющую какая из букв а или о встречается в тексте первой.

Помогите хотябы одну пожалуйста))Нужно до завтра!))

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Написать программу, которая выводит таблицу квадратов первых десяти целых положительных чисел (естественно, квадраты должны считаться В ЦИКЛЕ!). Ниже

представлен вид экрана во время работы программы, который вам нужно реализовать:

Таблица квадратов
-----------------------------
Число Квадрат
-----------------------------
1 1
2 4
и т.д.



Вы находитесь на странице вопроса "Написать программу, которая решает уравнение ax+b &lt;0 относительно x для любых чисел a и b , введёных с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.