Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ABCpaskal:С клавиатуры вводится строка, состоящая из букв и цифр. Написать программу , определяющую количество четных цифр в строке.ПОМОГИТЕ!!!СРОЧНО!!!

5-9 класс

Makoevmedik 20 июня 2014 г., 9:25:01 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lisenka12
20 июня 2014 г., 12:03:36 (9 лет назад)

uses crt;
var s1:string;
    s2:char;
    k,y,x:integer;
begin
     readln(s1);
     k:=0;
     for x:=1 to length(s1) do
         begin
              s2:=s1[x];
              if (ord(s2)<=57) and (ord(s2)>=48) then
                 if ord(s2) mod 2=0 then inc(y);
         end;
     writeln(y);
end.

+ 0 -
Tepuha
20 июня 2014 г., 14:18:17 (9 лет назад)

var
s1,s2:string;
i,j,k,m:longint;
begin
readln(s1);
k:=length(s1);
s2:='24680';
for i:=1 to k do
  for j:=1 to 5 do
    if s1[i]=s2[j] then inc(m);
writeln(m);
end.
ну вроде так, скомпилируй только перед отправкой или сдачей

+ 0 -
Ahr200mailru
20 июня 2014 г., 15:53:26 (9 лет назад)

var
s: string;
i,code,k,c: integer;

begin
readln(s);
for i:=1 to length(s) do
if s[i] in ['0'..'9'] then begin
Val(s[i],k,code);
if k mod 2=0 then inc(c)
end;
writeln(c)
end.

Ответить

Другие вопросы из категории

В трёх седьмых классах 70 ребят. Из них 27 занимаются в драмкружке, 32 поют в хоре, 22 увлекаются спортом. В драмкружке - 10 ребят из хора, в хоре -

6спортсменов, в драмкружке - 8 спортсменов; 3 спортсмена посещают и драмкружок, и хор.Сколько ребят не увлекаются ни хором, ни драмкружком и не спортом?Сколько ребят занято только спортом?

Читайте также

Для кодирования некоторой последовательности, состоящей из букв А, Б, В, Г и Д, используется неравномерный двоичный код, позволяющий однозначно

декодировать полученную двоичную последовательность. Вот этот код: А-11, Б - 10, В- 011, Г - 000, Д- 001. Можно ли сократить для одной из букв длину кодового слова так, чтобы код по-прежнему можно было декодировать однозначно? Коды остальных букв меняться не должны.

помогите пожалуйста..очень надо....что нибудь из этих задач..1)написать программу которая поменяет местами первую и последнюю букву в слове. 2)написать

программу которая вставит между буквами веденного слова пробелы 3)написать программу вывода на экран деление двух чисел

5-9 класс информатика ответов нет
Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

По программе Pascal.

1)Напишите программу определяющую средний балл учащихся группы.
Программа должна спрашивать:
₋ сколько в группе человек,
₋ какой средний балл у каждого учащегося.
2) Написать программу, определяющий сколько тыс. руб. пропали сегодня в столовой из -за отсутствия на занятиях некоторых учащихся по неизвестной причине.
Программа должна спрашивать:
₋ сколько человек было поставлено на заявку,
₋ сколько человек присутствовало на занятиях,
₋ сколько стоит обед для одного учащегося.
3) Написать программу в которой будет меняться буква А на букву Б (слово можно любое подобрать, например ШАЛАШ)
4) Написать программу, определяющую количество банок краски, необходимых для покраски всех дверей в помещениях (например в квартире) .
Программа должна спрашивать:
₋ сколько в квартире дверей,
₋ какая высота и ширина в среднем у одной двери,
₋ сколько кв. метров можно прокрасить из одной банки.



Вы находитесь на странице вопроса "ABCpaskal:С клавиатуры вводится строка, состоящая из букв и цифр. Написать программу , определяющую количество четных цифр в строке.ПОМОГИТЕ!!!СРОЧНО!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.