Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Составьте программу вычисления количества трёхзначных чисел, у которых сумма цифр является чётным числом.

5-9 класс

LizaUt 21 апр. 2015 г., 0:33:45 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vjhlfxrfksu
21 апр. 2015 г., 3:33:30 (9 лет назад)

uses crt;
var i,s,c,k,b:integer;
begin
s:=0;
k:=0;
for i:=100 to 999 do
begin
b:=i;
repeat
c:=b mod 10;
s:=s+c;
b:= b div 10;
until b=0;
if (s mod 2=0) then inc(k);
end;
writeln(k);
end.




Ответить

Другие вопросы из категории

используя генератор случайных чисел заполнить массив размерностью 20 элементов числами из интервала [-20,+25] вывести список элементов в одну строку 1

найти сумму четных элементов 2 подсчитать количество элементов массива равных2 3 обнулить все положительные элементы массива

Читайте также

Решите 2 программы. 1) Найдите количество двухзначных чисел, которые делятся на сумму своих цифр. 2) Составьте программу вычисления

количества трехзначных чисел, у которых сумма цифр является чётным числом.

ОЧЕНЬ СРОЧНО!!!

1.Составьте программу, выводящую на экран все двухзначные числа, у которых сумма цифр равна 8.

2.Составьте программу вычисления количества трёхзначных чисел палиндромов ( чисел, которые читаются одинаково слева направо и справа налево).
3.Найти двухзначные числа, которые делятся на сумму своих цифр
4.Составьте программу вывода количества трёхзначных чисел, у которых цифры упорядочены строго по убыванию.
РЕБЯТА СРОЧНО!!!!!!!!!!!



Вы находитесь на странице вопроса "Составьте программу вычисления количества трёхзначных чисел, у которых сумма цифр является чётным числом.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.