Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Напишите, пожалуйста, подробную задачу по информатике в Паскале. Содержание: В равномерном массиве А10 состоящих из целых чисел, если

10-11 класс

элемент положителен - увеличьте в 2раза, если отрицателен - заменить на 0.

Заранее спасибо! Пишите подробную задачу для программы Паскаль. Не забудьте пунктуацию.

Gruzdkov73 10 нояб. 2016 г., 5:57:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kat201
10 нояб. 2016 г., 6:33:29 (7 лет назад)

program lol;
var
a10:array[1..20] of integer;
i:integer;
begin
randomize;
for i:=1 to 20 do
begin
a10[i]:=random(50)-39;
writeln('Element #',i,': ',a10[i]);
end;
writeln;
for i:=1 to 20 do
begin
if a10[i] > 0 then a10[i]:=a10[i]*2;
if a10[i] < 0 then a10[i]:=0;
writeln('Element #',i,': ',a10[i]);
end;
readln;
end.

Ответить

Читайте также

Помогите пожалуйста с задачей по информатике!Без массива!Напишите в паскале!Очень надо!!

Опишите этапы решения на компьютере задачи нахождения значения a^b для целых чисел 0<a,b<10.

Помогите, пожалуйста, решить задачу по информатике)

1. Напишите программу формирования и вывода массива размером 6x3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-й — равен случайному числу;
2-й — равен целой части квадратного корня из предыду­щего элемента;
3-й-равен сумме двух предыдущих элементов.

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код

Помогите, пожалуйста, сделать задачи по информатике. Необходимо сделать на математическом языке и на паскале (желательно с объяснениями). Задача

2.

Все натуральные числа, начиная с 1, выписаны в одну строку без пробелов.Требуется написать программу, определяющую, какая цифра стоит в этой строке

на заданном месте.

Технические требования.

Имя входного файла: INPUT.TXT

Имя выходного файла: OUTPUT.TXT

Формат входных данных:

В единственной строке входного файла записано целое число N - длина слова (1 ≤ N≤ 100000000).

Формат выходных данных:

Выходной файл содержит одну искомую цифру.

Примеры файлов входных данных: Примеры файлов выходных данных:

21 5



Вы находитесь на странице вопроса "Напишите, пожалуйста, подробную задачу по информатике в Паскале. Содержание: В равномерном массиве А10 состоящих из целых чисел, если", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.