Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

в последовательности чисел введенных с клавиатуры подсчитать среднее арифметическое отрицательных четных чисел. Признак окончания ввода-0.

5-9 класс

Sovershenniy 11 нояб. 2016 г., 9:36:10 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gusrinova1987
11 нояб. 2016 г., 10:14:02 (7 лет назад)

program srednii_bal;
var b,i,s:real; a:integer;
begin
writeln('введите числа,чтобы закончить ввод введите число 0');
i:=0;
b:=0;
a:=1;
while a<>0 do begin
readln(a);
if (( a mod 2=0) and (a<0)) then  b:=b+(a);
if (( a mod 2=0) and (a<0)) then  i:=i+1;

end;
s:=b/i;

writeln('среднее значение равно ',s);

end.
все сам полностью проверил,полностью рабочая прога,если помог ставь ответ как лучший

Ответить

Другие вопросы из категории

иван решил найти все письма от адресата про электронный адрес которого помнит, что тот содержит подстроку ''petrov'' , в которой возможны ошибки ( но не

более двух). Сколько из нижепредставленных адресов электронной почты подходят Ивану?.
1) petrova_lada 2) misha_vetrov 3) veerovich 4) lida_peshova
А) 1 Б ) 2 В) 3 Г)4

Знайдіть помилки у наведених фрагментах програми, запишіть фрагмент правильно, пояснивши суть помилки:

а) x:=1; a:=81;

for i:=1 downto 10 do

begin

x:=x*i;

a:=a+2*i;

end;

б) х:=1; y:=1;

repeat

y:=y*x+2;

x:=x-2

until x-12;

продолжите предложения: а)изображение на экране монитора структуры готового к работе называется______________________ б)на рабочем столе

размещаются небольшие картинки объектов_________и_______________(картинки с небольшимы стрелочками в нижнем левом углу).

в)в____________________отправляется все то,что уже не нужно хранить в памяти компьютера

Читайте также

Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.

Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не является членом последовательности). Количество чисел не превышает 100. Введённые числа по модулю не превышают 300. Программа должна вывести среднее арифметическое чисел, кратных 9, или вывести NO, если таких чисел в последовательности нет.

Составить программу в паскале: Для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты.:

· Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел.

· Если произведение этих чисел больше их суммы, то выведите эти сумму и произведение.

· Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму

· Иначе, выведите удвоенные значения этих чисел

С клавиатуры вводятся целые числа. Окончание ввода – число ноль. Ноль используется

только для указания окончания ввода и в остальных расчётах не участвует. Подсчитать
среднее арифметическое тех отрицательных чисел, которые оканчиваются на цифру «5».
Учесть, что таких чисел может не быть. PascalABC

Напишите программу, которая в последовательность натуральных чисел определит значение наибольшего из всех нечетных введеный чисел. Программа

получает на вход целые числа, количество введеных чисел неизвестно, последовательность чисел заканчивается числом 0 (0 - признак окончания ввода, не входят в последовательность) .

Количество чисел не привышает 1000. Введеные числа не привышают 30000.

Программа должна вывести одно число - наибольшее из всех нечеиных введеных чисел.

Пример работы программы:

Входные данные Выходные данные

15 17

20

17

0



Вы находитесь на странице вопроса "в последовательности чисел введенных с клавиатуры подсчитать среднее арифметическое отрицательных четных чисел. Признак окончания ввода-0.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.