Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Задача: Определить Сумму элементов матрицы кратных 3

5-9 класс

Вот решение :
Program crh;
Const n=5; m=6;
Var a:array [1..N,1..M] of integer; i,s:integer;
Begin
For i:= 1 to N do
For k:= 1 to M do begin
write( 'Введите элемент массива');
Read(A[i,k]);
end;
For i:= 1 to N do
For k:= 1 to M do
if A mod 3 =0 then
s:=s+1;
write('Сумма элементов равна', s);
end.
Найдите ошибку, на строке if A mod 3 =0 then выдаёт ( операнды имеют неприводимые типы). Помогите сделать крч

Sta2005 26 апр. 2015 г., 3:29:12 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aleksandra1205
26 апр. 2015 г., 5:35:24 (9 лет назад)

ты не указал номер элемента массива, который считать будешь

Ответить

Другие вопросы из категории

Пусть а, b, с — логические величины, которые имеют следующие значения: а = истина, b = ложь, с = истина. Определите результаты вычисления следующих

логических выражений:
а и b; а и b или с; (а или b) и (с или b);
а или b; а или b и с; не (а или b) и (с или b);
не а или b; не а или b и с; не (а и b и с).

Читайте также

Помогите пожалуйста ! срочно надо!!!...в заданной последовательности целых чисел определите сумму элементов кратных 10! пример задачки вот именно под

типо по такой же системе которую щас напишу! program Maximum; i,n,max:integen; begin writeln ( 'введи элементы массива для поиска максимума'); for i:=1 to 10 do begin write ('a [', i ,']=');readln (a [ i ] ) ;end; max:=a[1]; for i = 2 to 10 do if a [ i ] > max then begin max:=a [ i ] ; n:= i ; end; writeln ('найти наибольший элемент ',max ,' под номером ', n); вот наподобие этого примера нужно построить мою задачу! в заданной последовательности целых чисел определите сумму элементов кратных 10. Помогите пожалуйста!!!

Пожалуйста помогите решить задачу: Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и

оканчивающихся на 4. Программа получает на вход натуральные числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4.

Пример работы программы:

Входные данные Выходные данные

14 168

24

144

22

12

0

Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход

натуральные числа, количество введенных чисел не известно, последовательность чисел заканчивается 0.

Количество чисел не превышает 100. Введенные числа не превышают 30000.

Программа должна вывести одно число: сумму двухзначных чисел, кратных 5.

Люди! Плиииз, помогите! Т,Т

написать программу которая в последовательности натур. чисел определяет сумму всех чисел кратных 8 и оканчивающихся на 4.программа получает на вход

натур. числа а также их количество.количество чисел не превышает 1000.программа должна вывести одно число:сумму всех чисел кратных 8 и оканч. на 4
ПОМОГИТЕ, ПОЖАЛУЙСТАА

Напишите программу, которая в последовательности натуральных чисел определяет сумму всех чисел, кратных 6 и оканчивающихся на 4. Программа получает на

вход натуральные числа через клавиатуру, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 – признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа не превышают 30 000. Программа должна вывести одно число: сумму всех чисел, кратных 6 и оканчивающихся на 4. Пояснение: цикл while x<>0 do с условием if (x mod 6=0) and (x mod 10=4)



Вы находитесь на странице вопроса "Задача: Определить Сумму элементов матрицы кратных 3", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.