Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Информатика!! Помогите пжл

5-9 класс

Lera34555 17 февр. 2014 г., 21:29:22 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
павеол
17 февр. 2014 г., 23:15:46 (10 лет назад)

var a, i:integer;   flag:boolean;
begin
     flag := true;
     writeln('Введите число и нажмите <Enter>');
     write('X= ');
     readln(a);
     if a = 1
     then
         writeln(a, ' - не простое число')
     else
          for i:=2 to (a div 2) do
              if a mod i = 0
              then
                  flag := false;
     if flag = true
     then
         writeln(a, ' - простое число')
     else
         writeln(a, ' - не простое число');
end.

+ 0 -
Alenachernickina
18 февр. 2014 г., 0:32:11 (10 лет назад)

Pascal?

+ 0 -
AngelZays
18 февр. 2014 г., 2:06:54 (10 лет назад)

да

Ответить

Другие вопросы из категории

Читайте также

Программа по информатике,Программа по информатике, помогите!Программа по информатике, помогите! Имеется n банок с целочисленными объемами

v1, v2, v3..., vn литров, пустой сосуд и кран с водой. Можно ли с помощью этих банок налить в сосуд ровно v литров воды.(Ответ должен выдаваться да или нет) Решение: обозначим s:=nod(v1, v2, v3..., vn) Если v делится нацело на s, то в сосуд с помощью банок можно налить v литров воды, иначе нет.Напишите программу пожалуйста,срочно и полностью, я вообще её не могу понять,помогите!!! :)

Найдите и исправьте ошибку в тексте

Информатика, помогите

информатика,помогите!!!


Вы находитесь на странице вопроса "Информатика!! Помогите пжл", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.