Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать в программе Паскаль программу:

5-9 класс

Вывести сначала положительные числа из отрезка [a;b], а потом отрицательные числа из отрезка [a;b] и количество положительных и отрицательных чисел из отрезка [a;b]

574895774685 13 нояб. 2013 г., 11:26:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Pufiya
13 нояб. 2013 г., 14:24:03 (10 лет назад)

var a,b,c,k:integer;
begin
read(a,b);
if (a<0) and (b>0) then  begin
for k:=1 to b do write (k,'   '); for k:=1 to a do write (-k, '   '); write(-a,'   ',b);
end
else if (a>0) and (b>0) then begin 
for k:= a to b do write (k,'   ');  write (b-a);
end
else b:=-1*b; a:=-1*a; for k:= b to a do write (k,'   ');  write (b-a);
end.

+ 0 -
Artemon123
13 нояб. 2013 г., 15:37:18 (10 лет назад)

uses crt;
const Q=10000;
var a:array [1..Q] of integer;
     x,k,p,m,n,o:integer;
begin
     write('a='); readln(m);
     write('b='); readln(n);
     a[1]:=m;
     for x:=2 to (n-m+1) do
         a[x]:=a[x-1]+1;
     write('Положительные: ');
     for x:=1 to (n-m+1) do

+ 0 -
ShtoPodelat
13 нояб. 2013 г., 16:37:46 (10 лет назад)

Вопрос, какие отрезки ? Записать их в виде рандома чисел или сделать массив чисел?!

+ 0 -
дариночка15
13 нояб. 2013 г., 19:35:33 (10 лет назад)

я думаю массив чисел, как нам объясняли, например, нужно написать n- количество чисел, пусть будет 7, а затем ввести этих 7 различных чисел по порядку и дальше по заданию, желательно решить через For или While или Repeat

+ 0 -
TheCrab
13 нояб. 2013 г., 20:16:01 (10 лет назад)

Хорошо, что-то придумаем

Ответить

Читайте также

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль



Вы находитесь на странице вопроса "Написать в программе Паскаль программу:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.