Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль Нужно было написать такую программу: 1) Площадь треугольника корень кв. из p(p-a)(p-b)(p-c), где p=a+b+c/2

5-9 класс

Написал программу следующим образом:

Ddi120702 02 марта 2014 г., 0:43:43 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
валерия225297
02 марта 2014 г., 2:11:12 (10 лет назад)

program ABD;
var a,b,c:integer;
p,S:real;
begin
writeln ('a,b,c');
readln (a,b,c);
p:=(a+b+c)/2;S:= sqrt(p*(p-a)*(p-b)*(p-c));
writeln ('S=',S:2:1);
end.
Это программа к первой задаче

Ответить

Другие вопросы из категории

Читайте также

Составить программу нахождения площади треугольника по формуле Герона.

Входные данные длины сторон треугольника.
Выходные данные периметр треугольника, площадь треугольника.

Pascal. Написать такую программу:

На вход получает N - количество элементов последовательности чисел.
Затем следуют элементы последовательности.
Программа должна вывести все отрицательные элементы последовательности, чьи квадраты не превосходят 7000, в порядке, обратном порядку их ввода.
Например на вход идут:
4
-3
6
-7
-99

На выходе получаем:
-7
-3

Я предлагаю такое начало программы:

program num9;
const N = 5;
var a : array [1..N] of integer;
i, m : integer;
begin for i := 1 to N do
readln (a[i]);
m := a[i];
if (m < 0) and (m*m < 7000) then

Как следует поступить дальше?

Помогите пожалуйста написать 2 программы

1)Написать программу которая меняет местами числа a и b(линейная и оператор присваивания)
2)Программа проверки существования треугольника по его 3 сторонам
Напишите пожалуйста***

1)Написать программу вычисления модуля разность двух данных целых чисел 2)Составить программу вычесляет в котором n суток, часов, минут,

секунд.

3)Составте программу вычисления площади треугольника с основанием а и высотой h. Значение a и h введите с клавиатуры.



Вы находитесь на странице вопроса "Паскаль Нужно было написать такую программу: 1) Площадь треугольника корень кв. из p(p-a)(p-b)(p-c), где p=a+b+c/2", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.