Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Написать программу на паскале. Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы. Помогите пж.

10-11 класс

Lkalashnikova 07 мая 2013 г., 16:38:35 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Аня19099
07 мая 2013 г., 17:48:43 (11 лет назад)

Const NN=50;
Var
a:array [1..NN,1..NN] of integer;
maxi,maxj,mini,minj,i,j,n,m:integer;
begin
writeln('Введите кол-во строк и столбцов массива: ');
readln(n,m);
for i:= 1 to n do
  for j:= 1 to m do
  begin
    write('a[',i,',',j,']= ');
    readln(a[i,j]);
  end;
writeln; writeln('Получившийся массив: ');
for i:= 1 to n do
  begin
    for j:= 1 to m do
      write(a[i,j]:4);
    writeln;
  end;
maxi:=1;
maxj:=1;
mini:=1;
minj:=1;
for i:= 1 to n do
  for j:= 1 to m do
  begin
    if a[i,j]>a[maxi,maxj] then
    begin
      maxi:=i;
      maxj:=j;
    end
    else if a[i,j]<a[mini,minj] then
    begin
      mini:=i;
      minj:=j;
    end;
  end;
writeln; writeln('Получившийся массив: ');
i:=a[maxi,maxj];
a[maxi,maxj]:=a[mini,minj];
a[mini,minj]:=i;
for i:= 1 to n do
  begin
    for j:= 1 to m do
      write(a[i,j]:4);
    writeln;
  end;
end.

Ответить

Другие вопросы из категории

Помогите пожалуйста!!!! Задайте массив из 10 элементов с помощью датчика случайных чисел. Замените все элементы с нечетными индексами

на минимальный. Выведите на экран исходный и полученный массивы.

прошу!!!!!срочно надо!!!ну приииииз!!!! это надо сделать в паскале! пожалуйста!кто нибудь!!!SOS!!!!!!

Задача на строки. в предложении все сочетания символов "ух" или "Ух" заменит на "ах". Посчитать количество слов в предложении.

Читайте также

Пожалуста!!!!!!!!!!!!!!!!!!!!!!ОЧ срочно!!!!!! Написать программу на паскале, которая вводит

массив из N целых чисел и выводит на экран номера отрицательных элементов и сами эти элементы. Протестировать программу для следующих массивов:

а) 3 5 -2 0 -6 -8 1

б) -1 -2 -3 0 -1 2 3

массивы должны вводися вручную а не рандомно.

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите пожалуйста с инфоматикой. Написать программу на паскале.

Дан двумерный массив из пяти строк и пяти столбцов. Найти сумму элементов первой стоки и произведение элементов второго столбца.

Народ,помогите написать программу на dev c++,объяснить)

В отчете предоставить блок-схемы всех
функций, текст программы.

Задача : В целочисленном массиве Х(N) удалить все элементы, расположенные
между максимальным и минимальным элементами. Найти среднее
арифметическое элементов массива до и после удаления. В программе
написать функции: удаления элемента, поиска номеров минимального и
максимального элементов, определения среднего арифметического
элементов массива.



Вы находитесь на странице вопроса "Написать программу на паскале. Создать двухмерный массив из целых чисел, в котором поменять местами максимальный и минимальный элементы. Помогите пж.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.