Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

А(20) Найти сумму элементов, стоящих на четных местах. Составить таблицу и программу

5-9 класс

Rostishishka 16 марта 2014 г., 12:25:46 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ionovamarina
16 марта 2014 г., 15:05:39 (10 лет назад)

var
n,i,s:integer;
a:array [1..20] of integer;
begin
readln (n);
s:=0;
for i:=1 to n do
 begin
readln(a[i]);
if i mod 2=0 then s:=s+a[i];
end;
writeln(s);
end.
Объясню. Если индекс элемента массива четный, то этот элемент прибавляется ка сумме и выводится.

+ 0 -
Zaiko34
16 марта 2014 г., 16:23:43 (10 лет назад)

Массив из 20 элементов? На Паскале?

+ 0 -
Veronika120294
16 марта 2014 г., 19:21:28 (10 лет назад)

да

+ 0 -
Ueptkmcfbn
16 марта 2014 г., 20:49:16 (10 лет назад)

хорошо

Ответить

Другие вопросы из категории

Перепишите программу на Паскале, исправив ошибки: Program massiv; Var a:array(-10..10) of integer; Begin For i:=1 to 20

Do

Read(a[i]);

For i:=1 to 20 Do

a[i]:=a[i]/10;

For i:=1 to 20 Do

Write(a[i])

End.

Даны три натуральных числа. Напишите программу, определяющую, существует ли треугольник с такими длинами сторон. Если существует, определите его тип

Имеются данные о количестве полных лет трех призеров спартакиады. Напишите программу, выбирающую и выводящую возраст самого младшего призера.

Читайте также

1)дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов

2)Дан массив целых чисел.Найти сумму четных положительных чисел, стоящих на нечетных местах и количество отрицательных элементов, стоящих на четных местах.
3)дан массив целых чисел.найти сумму четных и положительных элементов, расположенных до первого отрицательного элемента.Примечание:при вводе необходимо учесть, что первый элемент не может быть отрицательным.

составьте программу которая запрашивает значения элементов одномерного числового массива а, стоящего из 10 элементов,формирует и выводит на экран в

строку данный массив. Найти сумму неположительных элементов массива,количество элементов кратных 3, произведение элементов,стоящих на четных местах

Помогите решить задачи

1.Одномерный массив заполнен любыми числами. Заменить отрицательные элементы их модулями.
2.Одномерный массив заполнен целыми числами. Возвести в квадрат элементы, стоящие на четных местах.



Вы находитесь на странице вопроса "А(20) Найти сумму элементов, стоящих на четных местах. Составить таблицу и программу", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.