Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

составить программу для паскаля.1)Определить количество трехзначных чисел сума цифр которых равна числу N.2)Дано натуральное число N.Составить

10-11 класс

программу меняющихся местами первую и последнюю цифру.

Vikysya4981 19 авг. 2014 г., 1:12:21 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Новичок010
19 авг. 2014 г., 4:01:30 (9 лет назад)

1)uses crt;
var a:array[1..10] of integer;
c1,c2,c3,s,i,r,n:integer;
begin
for i:=1 to 10 do begin
a[i]:=random(300-100+1)+100;
write(a[i]:4);
end;
writeln;
write('Введите число N: ');
readln(n);
r:=0;
for i:=1 to 10 do begin
c1:= a[i] div 100;
c2:=a[i]-c1*100;
c2:=c2 div 10;
c3:=a[i]-c1*100-c2*10;
s:=c1+c2+c3;
if s=n then r:=r+1;
s:=0; c1:=0; c2:=0; c3:=0
end;
writeln('Количество чисел, сумма цифр которых равна ',n,', равно ',r);
end.

Я сделал, что числа даются случайные. Если нужно числа вводить, строку a[i]:=random(300-100+1)+100; заменяем на read(a[i]);

2)uses crt;
var N,x:integer;
a1,aX,b:string;
begin
write('Введите число N: ');
readln(n);
str(n,b);
x:=length(b);
a1:=copy(b,1,1);
ax:=copy(b,x,1);
delete(b,1,1);
delete(b,x-1,1);
b:=ax+b+a1;
writeln(b);
end.

 

 

 Во второй задаче в конце результат будет выводиться в виде текста, состоящего из цифр, то есть, дальнейшие арифметические операции над ним невозможны. Если нужно их проводить, то надо добавить строчки:
val(b,x,n);
write(x);

Ответить

Другие вопросы из категории

Для

таблицы истинности логической функции составить:
совершенную
дизъюнктивную и конъюнктивную формы функции,

ПАСКАЛЬ!!!

Нужно создать программу,которая проверяет принадлежность символа,вводимого с клавиатурі, символам %,^,&

Задание 2: Приведите примеры: · достоверной, но необъективной информации; · объективной, но недостоверной

информации;

· полной, достоверной, но бесполезной информации;

· неактуальной информации;

· актуальной, но непонятной информации.

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

Помогите пожалуйста решить задачи в турбо Паскале!

1) Определить количество двухзначных чисел, сумма цифр которых равна числу N.
2) Составить таблицу для двух столбцов выражения y=x²+3. Ввод чисел через клавиатуру.
3) Составить программу вычисления суммы кубов чисел от 1 до 5.
4) Вычислить сумму части ряда, 1/3, 1/6, 1/9, 1/12....
5) Среди двухзначных чисел, найти те, сумма цифр которых делятся на 3.
6) Найти самую большую цифру:
а) в двухзначном числе
б) трехзначном числе.

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Написать программу для Паскаль

Найдите среднюю температуру для дней, когда температура поднималась выше 0 градусов, и определите количество таких дней. Программа получает на входе количество дней, в течение которых проводилось наблюдение, затем для каждого дня вводится температура.



Вы находитесь на странице вопроса "составить программу для паскаля.1)Определить количество трехзначных чисел сума цифр которых равна числу N.2)Дано натуральное число N.Составить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.