Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Дан одномерный массив, состоящий из 10 целых элементов. Найдите номера четных элементов, стоящих на нечетных местах.

10-11 класс

Elizavetanas 19 февр. 2014 г., 15:45:45 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Metelyova96
19 февр. 2014 г., 17:21:17 (10 лет назад)

var a:array[1..100]of integer;
nol,chet,nechet,i,n:integer;
begin
readln(n);
for i:=1 to n do begin
 readln(a[i]);
if (a[i] mod 2=0)and(a[i]<>0) then chet:=chet+1;
if (a[i] mod 2=1) then nechet:=nechet+1;
if a[i]=0 then nol:=nol+1;
end;
writeln('четных :',chet,' ','нечетных :',nechet,',' ',нулевых :',nol);
end.

Ответить

Другие вопросы из категории

Читайте также

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

составьте программу,которая запрашивает значение элементов одномерного массива A,состоящего из 10 элементов,формирует и выводит на экран в строку данный

массив.Найти сумму определённого элемента;количество элементов,стоящих на нечетных местах;произведение элементов,кратных 5.

В одномерном массиве, состоящем из n целых элементов, вычислить:


1) Сумму модулей элементов массива, больших числа X

2)Сумму модулей элементов массива, меньших числа X



Вы находитесь на странице вопроса "Дан одномерный массив, состоящий из 10 целых элементов. Найдите номера четных элементов, стоящих на нечетных местах.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.