Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то

10-11 класс

вычислить площадь этого треугольника. Даны два действительных положительных числа х и у. Арифметические действия над числами пронумерованы (1 - сложение, 2 - вычитание, 3 - умножение, 4 - деление). Составить программу, которая по выведенному номеру выполняет то или иное действие над числами.

Мэри13 25 апр. 2013 г., 17:05:28 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ggg8
25 апр. 2013 г., 17:53:49 (11 лет назад)

program task1;
var  a, b, c, p, s :real;
begin
  readln(a,b,c);  if (a + b > c) and (a + c > b) and (b + c > a) then  begin    writeln('Могут быть сторонами треугольника');    p:= (a + b + c)/2;    s:= sqrt( p * (p - a) * (p - b) * (p - c) );    writeln('Площадь равна ',s);  end  else    writeln('Не могут быть сторонами треугольника');
end.

program task2;
var  a, b, c :real;  d :integer;
begin
  write('Введите числа: ');  readln(a,b);  write('Введите номер действия: ');  readln(d);  case d of    1: c:= a + b;    2: c:= a - b;    3: c:= a * b;    4: c:= a / b;  end;  writeln(c);
end.

Ответить

Другие вопросы из категории

квантование сигнала это?
Телеграфистка в течение пяти минут пере-

давала информационное сообщение со
скоростью 20 байт в секунду. Сколько
символов содержало данное сообщение,
если она использовала алфавит из 32 сим-
волов?

Вводится 15 чисел. Определить сколько из них целые числа.

Помогите пожалуйста составить программу в паскале.

помогите решить номера 7,8,9

Читайте также

Дано целое положительное число. Проверить истинность высказывания: «данное число является нечетным трехзначным».

Входные данные: ввести одно целое положительное число a ((1<=a<=1000).
Выходные данные: вывести слово «true» если приведенное высказывание для предложенных исходных данных является истинным или «false» в противном случае.



Вы находитесь на странице вопроса "Помогите с задачками в паскале. Даны три положительных числа а, в, с. Проверить будут ли они сторонами треугольника. Если да то", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.