Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан массив состоящий из 20 элементов. Найти сумму и кол-во элементов отрицательных и кратных 5. Пожалуйста,срочно надо!

5-9 класс

BorodaTW 28 нояб. 2013 г., 8:48:09 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Полиша96
28 нояб. 2013 г., 9:54:08 (10 лет назад)

Program n1;
Uses CRT;
Const n=20;
Var a: array[1..n] of integer;
i,k,s: integer;
begin
For i:=1 to n do
begin;
a[i]:=random(50)-25;
write(a[i],' ');
if (a[i] mod 5=0)and(a[i]<0) then
begin
k:=k+1;
s:=s+a[i];
end;
end;
writeln('Kolichestvo =',k,' Summa=',s);
readln
end.

Ответить

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.

Решить задачи на языке программирования в Turbo Pascal: 1) Дан массив, состоящий из 10 чисел, значения могут быть

от -100 до 100. Определить минимальное положительное число.

2) Дан массив, состоящий из 10 чисел. Найдите номера тех элементовв масива, которые наименее различаются.

1. Дан массив А из 10 элементов, которые заполняются случайным образом, числам от 0 100. Выведите массив на экран и найдите максимальный элемент массива.

2. Создать массив A из 10 элементов, заполненный случайным образом числами принадлежащих промежутку (0;20). Вывести полученный массив на экран. Вычислить количество элементов массива, значения которых не превышают среднее арифметическое значений его элементов.



Вы находитесь на странице вопроса "Дан массив состоящий из 20 элементов. Найти сумму и кол-во элементов отрицательных и кратных 5. Пожалуйста,срочно надо!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.