Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вам даны число N и цифра D.Выведите все N-значные числа,которые не содержат цифру D, в возрастающем порядке.

10-11 класс

исуля 02 янв. 2015 г., 13:46:26 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VladimirTula
02 янв. 2015 г., 15:01:12 (9 лет назад)

var a,b:integer;
begin
writeln('Введите число');
readln(a);
writeln('Введите цифру');
read(b);
if ((a mod 10)<>b) and ((a div 10)<>b) and (a<100) then begin
a:=a+1;
write(" ",a);
end;
end.

Ответить

Другие вопросы из категории

напишите ответ

определить площадь стен помещения 4,если высота помещения -3 метра

ПОЖАЛУЙСТААА,ПОМОГИТЕ.Ну,очеень надо

Сколько таких учебников может поместиться на дискете 1,44 Мб, на винчестере в 1 Гб.

4. В детской игре «Угадай число» первый участник загадывает целое число от 1 до 32. Второй участник задает вопросы: «Загаданное число больше числа ___?». Какое количество вопросов при правильной стратегии гарантирует угадывание?

Читайте также

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

1. Дано натуральное число n. Переставить его цифры так, чтобы образовалось максимальное число, записанное теми же цифрами.

2. Найти все двузначные числа, сумма квадратов которых делится на 17.

Всё это нужно сделать в программе Паскаль, но КАК?!

1)составить блок-схему поиска двузначных чисел,таких,что если к сумме цифр этого числа прибавить квадрат этой суммы,то получится это число.

2)построить блок схему которая меняет порядок цифр числа на обратный. например было 12345,стало 54321.

Однажды, посетив магазин канцелярских товаров, Вася купил X карандашей, Y ручек и Z фломастеров. Известно, что цена ручки на 2 рубля больше цены

карандаша и на 7 рублей меньше цены фломастера. Также известно, что стоимость карандаша составляет 3 рубля. Требуется определить общую стоимость покупки.

Входные данные

В единственной строке входного файла INPUT.TXT записаны три натуральных числа X, Y и Z через пробел, каждое из которых не превышает 109.

Выходные данные

В выходной файл OUTPUT.TXT выведите одно целое число – стоимость покупки в рублях.



Вы находитесь на странице вопроса "Вам даны число N и цифра D.Выведите все N-значные числа,которые не содержат цифру D, в возрастающем порядке.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.