Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 – сложение, 2 – вычитание, 3 – умножение, 4 –

5-9 класс

деление. Дан номер действия n и вещественные числа a, b (b<>0). Выполнить над числами указанное действие и вывести результат. Например, n=2, а=0,40, в=1,00. Результат: а-в=-0,60. Единицы длины пронумерованы так: 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр. Дан номер единицы длины и длина отрезка в этих единицах (вещественное число). Найти длину отрезка в метрах.

Danchig1997 06 апр. 2014 г., 20:57:47 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
лиза5647463474633
06 апр. 2014 г., 22:16:10 (10 лет назад)

var

  d:integer;

  a,b:real;

begin

  write('a = '); readln(a);

  write('b = '); readln(b);

  write('Введите номер операции '); readln(d);

  case d of

    1: writeln(a, ' + ', b, ' = ', a + b);

    2: writeln(a, ' - ', b, ' = ', a - b);

    3: writeln(a, ' * ', b, ' = ', a * b);

    4: begin

        if b <> 0 then

          writeln(a, ' / ', b, ' = ', a / b)

       else

          writeln('делить на 0 нельзя');

     end;

    else

       writeln('Неизвестная операция');

  end;

end.

   

 

 

//вторая программа

 

var

  d:integer;

  a:real;

begin

  write('Длина отрезка = '); readln(a);

  write('Введите код единицы измерения '); readln(d);

  case d of

    1: writeln('Длина отрезка ', a / 10, ' метр(а, ов)');

    2: writeln('Длина отрезка ', a * 1000, ' метр(а, ов)');

    3: writeln('Длина отрезка ', a, ' метр(а, ов)');

    4: writeln('Длина отрезка ', a / 1000, ' метр(а, ов)');

    5: writeln('Длина отрезка ', a / 100, ' метр(а, ов)');

    else

       writeln('Неизвестная единица длины');

  end;

end.

+ 0 -
Danyamiron
06 апр. 2014 г., 23:06:59 (10 лет назад)

{ 1 – дециметр, 2 – километр, 3 – метр, 4 – миллиметр, 5 – сантиметр.}
var
    units: integer;
    value, factor: real;

begin
    write('Введите значение - '); readln(value);
    write('Введите единицу измерения - '); readln(units);
    case units of
        1: factor := 0.1;
        2: factor := 1000;
        3: factor := 1;
        4: factor := 0.001;
        5: factor := 0.01;
    else
        factor := 1;
    end;
    
    writeln(value * factor, ' м');
end.

Ответить

Другие вопросы из категории

Який перший обчислюваний прилад
1 байт-2^3битов1Кбайт-2^? битов-2^10Кбайт1Мбайт-2^? битов-2^& байтов-2^10Кбайт1Гбайт-2^?битов-2^?

байтов-2^?Кбайт-2^10Мбайт1Тбайт-2^?битов-2^?байтов-2^?Кбайт-2^?Мбайт-2^10Гбайт1Пбайт-2^?битов-2^?байтов-2^?Кбайт-2^?Мбайт-2^?Гбайт-2^10Тбайт
УМОЛЯЮ ОЧ НАДО

Читайте также

Даны два действительных положительных числа x и y. Арифметические действия над числами пронумерованы (1 – сложение, 2 – вычитание, 3 – умножение, 4 –

деление). Составьте программу, которая по введенному номеру выполняет то или иное действие над числами

СОСТАВИТЬ ПРОГРАММУ НА ПАСКАЛЕ.

Агент 007 узнал, что в секретном сейфе трёхзначный код, в котором все три цифры разные.При этом средняя цифра равна разности крайних цифр. Составить программу, которая напечатает для него все такие числа.

4 а) составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 , затем элементы с четными индексами

удваиваются , а элементы с нечетными индексами утраивает.Выведите на экран исходный и полученный массив.

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 , затем изменяет знак элементов с четными индексами на противоположный .Выведите на экран исходный и полученный массивы.

5) а)составьте программу ,которая заполняет массив а[1..10 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит количество элементов ,которые больше своего соседа слева

б)составьте программу ,которая заполняет массив b[1..8 ] случайными целыми числами в диапозоне от 1 до 10 и находит количество пар элементов с четными значениями.

6) а)составьте программу ,которая заполняет массив а[1..20 ] случайными целыми числами в диапозоне от 1 до 10 ,и находит среднее арифметическое элементов с четными значениями и нечетными индексами.

б) составьте программу ,которая заполняет массив b[1..15 ] случайными целыми числами в диапозоне от 1 до 20 и выводит все тройки элементов , упорядоченные строго по возрастанию.

1) Составьте программу вычисления в массиве A(N) суммы всех чисел, кратных 3. 2) Составьте программу вычисления в массиве B(8) суммы отрицательных

элементов. 3) Составьте программу вычисления среднего арифметического элементов массива. Пожалуйста.. очень надо!

Составить программу, определяющую, является ли данное утверждение истинным:Двузначное число А начинается на 3

Составить программу, определяющую, является ли данное утверждение истинным:Ровно одно из чисел А и В не превышает 100



Вы находитесь на странице вопроса "помогите! я ничего не понимаю! составьте программу! Арифметические действия над числами пронумерованы так: 1 – сложение, 2 – вычитание, 3 – умножение, 4 –", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.