Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Даю много баллов за решение!

5-9 класс

написать программу по которой
найти минимальный и максимальный элемент массива и все элементы между ними заменить 0...(10,50)
Срочно

Artemmaslennik 18 нояб. 2014 г., 5:31:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Fatal15
18 нояб. 2014 г., 6:29:03 (9 лет назад)

var
  a: array of integer;
  i, n, min, max,k,m: integer;
begin
write('Размер массива: ');
readln(n);
setlength(a, n+1);
writeln('Исходный массив:');
for i:=1 to n do
   begin
   a[i]:=random(10,50);
   write(a[i]:4);
   if a[i]>max then
     begin
     max:=a[i];
     k:=i;
     end;
   if a[i]<min then
     begin
     min:=a[i];
     m:=i;
     end;
   end;
writeln;   
min:=a[1];
max:=a[1];
for i:=2 to n do
   begin
   if a[i]>max then
     begin
     max:=a[i];
     k:=i;
     end;
   if a[i]<min then
     begin
     min:=a[i];
     m:=i;
     end;
   end;   
if k<m then
  for i:=k+1 to m-1 do a[i]:=0
  else
    for i:=m+1 to k-1 do a[i]:=0;
writeln('min=',min);
writeln('max=',max);  
writeln('Преобразованный массив:');
for i:=1 to n do write(a[i]:4);
end.

+ 0 -
Nastua5149762
18 нояб. 2014 г., 8:32:55 (9 лет назад)

я написала огромную прогрумму

+ 0 -
Slydin59
18 нояб. 2014 г., 9:49:46 (9 лет назад)

вбмвала каждый символ

+ 0 -
UNY
18 нояб. 2014 г., 12:45:19 (9 лет назад)

а тебе сложно помочь мне исправить ошибки?

+ 0 -
Светик144
18 нояб. 2014 г., 14:18:16 (9 лет назад)

это дело 2-3 минут

+ 0 -
Kudelina99
18 нояб. 2014 г., 15:20:01 (9 лет назад)

для тебя

Ответить

Другие вопросы из категории

1. Как называется свойство алгоритма,1. Как называется свойство алгоритма, означающее, что данный алгоритм применим к решению целого класса задач?

а) понятность
б) определённость
в) результативность
г) массовость
2. Как называется свойство алгоритма, означающее, что он всегда приводит к результату через конечное, возможно, очень большое число шагов?
а) дискретность
б) понятность
в) результативность
г) массовость
3. Как называется свойство алгоритма, означающее, что он задан с помощью таких предписаний, которые исполнитель может воспринимать и по которым может выполнять требуемые действия?
а) дискретность
б) понятность
в) определённость
г) массовость
4. Как называется свойство алгоритма, означающее, что пусть решения задачи разделён на отдельные шаги?
а) дискретность
б) определённость
в) результативность
г) массовость
5. Как называется свойство алгоритма, означающее, что путь решения задачи определён вполне однозначно, на любом шаге не допускаются никакие двусмысленные и недомолвки?
а) дискретность
б) понятность
в) определённость
г) результативность

2 задачи по программированию: 1) Три точки заданы своими координатами (x1,y1),

(x2,y2), (x3,y3). Напишите программу, позволяющую выяснить, какие из них находятся на максимальном расстоянии друг от друга, и вывести на печать значение этого расстояния. Вычисление расстояния между двумя точками оформите в виде процедуры.

2) Даны действительные числа Х и Y. Напишите программу, позволяющую вычислить значение следующего выражения:

Z=(signX + signY)*sign(X+Y),

Информационный объём статьи 48 Кбайт. Сколько страниц займёт статья, если на одной странице электронного документа помещается 64 строки по 64 символа,

а каждый символ представлен кодировке в KOI-8 (в кодировке KOI-8 каждый символ занимает 8 бит памяти

Читайте также

Люди,кто желает выполнить практическое задание за 8 класс ,очень срочно,поэтому даю много баллов! Вот задание!!!

Практическое задание

Открой
файл кр1-1.docx.
Выполни редактирование и форматирование текстового документа так, чтобы его вид
совпал с образцом текста, выданного учителем:

Ребят сделайте пожалуйста с помощью программы Паскаль задания номер 7.и задание номер 5. Завтра сдавать д.з а у меня программа не работает(( решите и

пришлите решение задач!..Даю хорошие баллы за это задание.Всем большое спасибо!

Даю много баллов!ПАСКАЛЬ!Только решите!С подробной записью всей программы и ответом!Даны 2 массива А и В по 20 элементов.Сформировать массив с=А+В,в

полученном массиве найти сумму элементов,имеющих чётный индекс.Запишите подробно всю прграмму...Прошу.Работаем с Паскалем(((



Вы находитесь на странице вопроса "Даю много баллов за решение!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.