Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Запишите на языке Паскаль программу циклического обмена значениями трёх переменных

5-9 класс

a,b,c.

Схема циклического обмена:

a <- b <- c

I ^

I I

v--------->

Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.

бананчик0078 17 июля 2013 г., 20:47:42 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ffddfjjhvh
17 июля 2013 г., 22:53:01 (10 лет назад)

program cikl;

var a,b,c,i,j,k:integer;

 

begin

writeln('BBedute A,B,C');

readln(a,b,c);

i:=a;

j:=b;

k:=c;

a:=j;

b:=k;

c:=i;

writeln('a=',a,'b=',b,'c=',c);

readln

end.

+ 0 -
ПончиксоняСонька
18 июля 2013 г., 0:41:10 (10 лет назад)

var a,b,c,a1,b1,c1:real;

begin

readln(a,b,c);

b1:=a;

c1:=b;

a1:=c;

writeln(a1,b1,c1);

end.

Ответить

Другие вопросы из категории

ПОМОГИТЕЕЕЕЕЕЕЕЕ!!!!!!

Запишите по 2 суждения:
Из истории-
Из географии-
Из биологии-
Из математики-
Из русского языка-
Из литературы-
Из информатики-
ПОМОГИТЕ! ПОЖАЛУЙСТА!

Читайте также

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль

Плиз срочно надо.1)Найдите правильную на языке паскаль запись выражения

19(16,3+7,7).а)19(16.3+7.7),в)19*(16.3+7.7).д)19(16,3+7.7).с)19*(16.3+7.7).2)Найдите правильную на языке паскаль записы выражения \frac{34,5+24,5}{15y}.а)34.5+24.5/15у в)(34.5+24.5)/15у с)(34.5+24.5)15*у.д)(34.5+24.5)/(15*у).3)Вычислите длину окружности и площадь круга одного и того же заданного радиуса R.4)Даны два числа.Найдите среднее арифметическое кубов этих чисел и среденее геометрическое модулей этих чисел.Два последних номера там нужно написать программу,программу присылать на листочке

Домашнее задание:

1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет
сумму и произведение его цифр.



Вы находитесь на странице вопроса "Запишите на языке Паскаль программу циклического обмена значениями трёх переменных", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.