Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны натуральное число n и целые числа a1, a2,...an. Получить: а)а1-а2+а3-...; б)а1+аn; в)а1-а2.

5-9 класс

Пожалуйста, ребятушки, в паскале.
Очень ваша помощь нужна;*

Anastasiya2802 31 мая 2014 г., 12:43:52 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Maxabbat82t
31 мая 2014 г., 14:48:54 (9 лет назад)

var a:array[1..1000] of integer;

n,i,s1,s2,s3:integer;

s1:=0;

read(n);

for i:=1 to n do

read(a[i]);

for i:=1 to n do

if i mod 2 = 1 then s1:=s1+a[i] else s1:=s1-a[i];

s2:=a[1]+a[n];

s3:=a[1]-a[2];

writeln(s1,' ',s2,' 's3);

end.

 

+ 0 -
ПростоЦарь225
31 мая 2014 г., 16:02:43 (9 лет назад)

Можно обойтись без массива:

 

Program Meredith;
var n,i,a,b,v,a1,a2,temp:integer;
  begin
  writeln('*   alphaues is thinking...   *');
  write('Ok, введите число N =');
  readln(n);
  a:=0;
  for i:=1 to n do
    begin
      write('Введите ',i,'-e число ');
      readln(temp);
      if i mod 2 = 1 then a := a + temp else a := a - temp;
      if i = 1 then a1 := temp;
      if i = 2 then a2 := temp;
    end;
  writeln('Задание а: ',a);
  writeln('Задание б: ',a1+temp);
  writeln('Задание в: ',a1-a2);
  writeln('*******************************');
end.

Ответить

Другие вопросы из категории

ПОМОГИТЕ

Черно-белое изображение имеет 8 градаций яркости. Размер изображения 10*15 см. Разрешение 300 точек на дюйм (1 дюйм = 2,5 см). Сколько Кбайт памяти требуется для хранения изображения в несжатом виде?
Заранее спасибо!

Один из первых отечественных персональных компьютеровБК-0010 имел оперативную память 16 Кбайт.Сколько страниц текста можно было бы разместить в памяти

этого компьютера, если на странице размещается 40 строк по 60 символов в каждой строке, а для хранения одного символа требуется 8 битов?

два сообщения содержат одинаковое количество символов.Количество информации в первом тексте в 1,5 раза больше,чем во втором.Сколько символов содержат

алфавиты,с помощью которых записаны сообщения,если известно,что число символов в каждом алфавите не превышает 10 и на каждый символ приходится целое число битов?

Читайте также

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".

Ребята кто разбирается в Pascal ABC помогите пожалуйста Задачи на циклы с параметром 1.Дано вещественное число A и целое число N (> 0).

Вывести A в степени N: An = A•A•...•A (числа A перемножаются N раз). 2.Дано вещественное число A и целое число N (> 0). Вывести все целые степени числа A от 1 до N. 3.Дано вещественное число A и целое число N (> 0). Вывести 1 + A + A2 + A3 + ... + An. ,

Введите с клавиатуры целое число в диапазоне 1-999.

а)Определите количество знаков в числе;
б)Определите четность числа;
в)Выведите описание числа,например,"нечетное однозначное число","четное двухзначное число" и тд.
Пример ввода: 347
Пример вывода: Нечетное трехзначное число

Введите с клавиатуры целое число в диапазоне 1-999.

а) определите количество знаков в числе;
б) определите чётность числа;
в) выведите описание числа ,наприме нечётное одназначное число чётное двухзначное число

Ввести целое число и найти сумму его цифр.

Пример:
Введите целое число:
1234
Сумма цифр числа 1234 равна 10.



Вы находитесь на странице вопроса "Даны натуральное число n и целые числа a1, a2,...an. Получить: а)а1-а2+а3-...; б)а1+аn; в)а1-а2.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.