Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Племя Амазонка имеет256-и символьный алфавит.Племя Омега использует 128-и символьный алфавит.Вожди племени обменялись письмами .Письмо племени Амазонка

10-11 класс

содержало 1245 символов,а письмо племени Омега 1987 символов. Сравните объёмы информации,содержащиеся в письмах.

Maleshka 03 янв. 2014 г., 17:04:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
PolinkaPastushka
03 янв. 2014 г., 19:31:59 (10 лет назад)

2^x=N

x - информационный вес одного символа

N - мощность алфавита (кол-во символов)

 

Размер содержащейся в тексте информации находим по формуле: 

I = K \cdot x 

K - кол-во символов в тексте 

 

Амазонка 

2^x=256 \\ 2^x=2^8 \\ x=8 

- один символ несет 8 битов (1 байт)

I = K \cdot x \\ I = 1245 \cdot 8 \\ I = 9960

- байт в письме Амазонки

 

Омега: 

2^x=128 \\ 2^x=2^7 \\ x=7  

один символ несет 7 битов

I = K \cdot x \\ I = 1987 \cdot 7 \\ I = 13909

байт в письме Омеги 

 

Ответить

Другие вопросы из категории

Помогите в с++ билдер. В строке, состоящей из групп нулей и единиц, подсчитать количество символов в самой длинной группе.(напишите код в консоли)...

вот пример который считает количество едениц в строках с нечётным количеством символов
//---------------------------------------------------------------------------

#include
#include
#include
#include
#pragma hdrstop

//---------------------------------------------------------------------------

#pragma argsused
int main(int argc, char* argv[])
{
int n,s, i, nst,p,k, len,t=0;
char a[81];
puts(" Input string ");
gets(a);
len = strlen(a);
s=0;
n=0;
a[len+1]='\0';
a[len]=' ';
for(i=0; i<=len; i++)
{
if(a[i]!=' ')
{
n++;
if(a[i]=='1')
t++;
}
else
{
if(n%2!=0)s+=t;
n=0;
t=0;
}
}
printf("\nkoli4ectvo 1= %d", s);
puts("\nPress any key to close ... ");
getch();
return 0;
}
//---------------------------------------------------------------------------

Заданы первый член арифметической прогрессии а, разность прогрессии d и количество членов прогрессии k. Вычислить k-1 и к-ые члены арифметической

прогрессии и сумму первых n членов Sn. Если Sn≤25, то вычислить процентное отношение первого и последнего членов арифметической прогрессии . Написать программу на языке Паскаль

Помогите, пожалуйста составить программу:)

В массиве а1, а2, ..., а50 определить
количество нулей

Читайте также

одно племя имеет 32-символьный алфавит, а второе племя 64-символьный алфавит. вожди племен обменялись письмами. письмо первого племени содержало 80

символов, а письмо второго племени 70 символов. сравните объем информации, содержашийся в письмах

Племя Мульти пишет письма, пользуясь 16 - символьным алфавитом. Племя Пульти пользуется 64-символьным алфавитом. Вожди племен обменялись письмами. Письмо

племени Мульти содержало 100 символов, а письмо племени Пульти — 50 символов. Сравните объёмы информации, содержащиеся в письмах.
Письмо Пульти = 75% Письма Мульти
Письмо Пульти = 50% Письма Мульти
Письмо Мульти = 75% Письма Пульти
Письмо Пульти = 60% Письма Мульти

1. сколько символов содержит сообщение записанное с помощью 256 символьного алфавита если объем его составил 1/64 часть Мбайта?

2. Сообщение занимает 2 страницы по 60 строк и содержит 7200 байтов информации. Сколько символов в строке если при составлении этого сообщения использовали 256 символьный алфавит?
Срочно нужно помогите! и объяснение пожалуйста

!!! помогите !!! очень !!! срочно !!! 7 класс !!! если что !!!

№11 информационное сообщение объемом 375 байтов состоит из 500 символов. Каков информационный вес каждого символа этого сообщения? Какова мощность алфавита с помощью которого было записано это сообщение

№12 Для записи текста использовался 64-символьный алфавит.
Какое кол-во информации в байтах содержат 3 страницы текста, если на каждой странице расположено 40 строк по 60 символов в строке ?

№13 Сообщение занимает 6 страниц по 40 строк, в каждой строке за-
писано по 60 символов. Информационный объем всего сообщения равен 9000 байтам . Каков информационный вес одного символа? Сколько символов в алфавите языка, на котором записано это сообщение



Вы находитесь на странице вопроса "Племя Амазонка имеет256-и символьный алфавит.Племя Омега использует 128-и символьный алфавит.Вожди племени обменялись письмами .Письмо племени Амазонка", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.