Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Паскаль Задача Сколько раз выполнится цикл? q:=25; p=:33; repeat q:=q+2; p:=p+3; until (q div 5) <> (p

5-9 класс

div 7);

Составить программу

коалла 28 сент. 2013 г., 17:50:07 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Merkulovaschura
28 сент. 2013 г., 20:42:33 (10 лет назад)

uses crt;
var q,p,k:integer;
begin
q:=25;    p:=33;
repeat
q:=q+2;
p:=p+3;
inc(k);
until (q div 5) <> (p div 7);
k:=k-1;
writeln(k);
end.
Цикл выполнится 4 раза

+ 0 -
МаЛыШкА42
28 сент. 2013 г., 23:31:07 (10 лет назад)

Цикл будет выполнен 5 раз.

Ответить

Другие вопросы из категории

Здравствуйте! У меня есть просьба) Я учусь в техникуме и нам нужно сделать лабораторные работы. Может уже кто то такие делал, скиньте пожалуйста) Например

вот работа #13 Задание 1. Создайте папку с названием Лабораторная работа №13_ваша фамилия. Задание 2. Создайте три рисунка согласно вашему варианту в редакторе Paint и вставьте их в отчет. Задание 2. Создайте схему полусумматора двоичных чисел в редакторе Paint и вставьте ее в отчет.

Помогите пожалуйста мне еще надо схему

Заранее спасибо

помогите решить в Паскале

Читайте также

1)в какой структуре цикла операторы "тела" цикла обязательно выполняются хотя бы один раз?

2)В операторе while A do B, на месте B ставится?
3)Сколько раз выполнится цикл
A:=1;
while A<=5 do
A:=A+1;
4)В операторе while A do B; на месте A ставится?
5)Какой оператор в цикле должен присутствовать для правильного его завершения?
6) В какой из циклических структур операторы тела цикла не надо заключать в "операторные скобки"?
7)После выполнения операторов
K:=0;S:=0;
while K>10 do
S:=S+K;
K:=K+2;
Ps. Это все паскаль.

30.

Дан фрагмент программы (все используемые переменные имеют целый тип данных).
на языке Паскаль​на языке Бейсик
P:=1; A:=1;​P=1: A=1
while P<16 do​WHILE P<16
begin​ A=2*A
A:=2*A; P:=P*A;​ P=P*A
end;​WEND
Определите, сколько раз выполнится тело цикла.
1.3​ 2.4​ 3.бесконечно много раз​ 4.16​ 5.0

Помогите, пожалуйста, выполнить задания, связанные с Turbo Pascal:


1. Сколько раз выполнится тело цикла и какие значения будут

присвоены переменной I?

I:=1;

While I<=10 do

I:=I+1;

2. Что появится на экране в результате работы этих программ?

а) Program primer1;

Var X:real; I:integer;

Begin I:=1; X:=0;

While I<=5 do begin

X:=X/2+I*I;

I:=I+1;

End;

Write(X);

End.

b) Program primer2;

Var X,I,N:integer;

Begin

Write ('введите число');

Readln(X);

I:=1;

While I<=X do begin

If X mod I=0 then N:=N+1;

I:=I+1;

End;

Write(N,I);

End.

(если X=12)

Сколько раз выполнится тело цикла

for n:=3 to 6 do write( ' * ' ) ;?

Сколько раз выполнится тело цикла?

For x:=2 to 7do write (' * ');
For x:=3 to 3do write (' * ');
For x:=5 to 2do write (' * ');
For x:=5downto 5do write (' * ');
For x:=10 downto 4do write (' * ');
For x:=1 downto 4do write (' * ');



Вы находитесь на странице вопроса "Паскаль Задача Сколько раз выполнится цикл? q:=25; p=:33; repeat q:=q+2; p:=p+3; until (q div 5) &lt;&gt; (p", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.