Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Запишите функцию для получения случайного числа x из промежутка: [0; 15) [0; 15] [-15; 15) [10; 15)

5-9 класс

Arinchik2308 08 янв. 2014 г., 13:40:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
KseniaEt
08 янв. 2014 г., 16:33:44 (10 лет назад)

function Random_Range(x, y : Integer) : Integer;
begin
    Random_Range := Random(y) - x;
end;

 

var
   i : Integer;
begin

   Randomize;

 

   Writeln( Random_Range(0, 15) ); // [0; 15)
   Writeln( Random_Range(0, 16) ); //[0; 15] 
   Writeln( Random_Range(15, 30) ); //[-15; 15) 
   Writeln( Random_Range(-10, 5) ); //[10; 15)

   ReadLn; 
end.

Ответить

Другие вопросы из категории

помогите решить красворд

1. Наглядный способ представления числовых данных. 9 букв
2. рисунки, схемы, диаграммы позволяют представлять информацию......
3. Позволяет представить, как устроены окружающие объекты и как они связаны с друг другом. 8 букв
4. Помогает читателю очень быстро понять, о чём идёт речь, и создать в его представлении определённый образ. 11 букв
5. Любое словесное высказывание, напечатанное, написанное или существующее в устной форме. 5 букв
7. Диаграмма, данные на которые изображаются в виде секторов круга. 8 букв
8. Форма представления однотипных данных. 7 букв
9. Диаграмма, данные на которой изображаются в виде вертикальных прямоугольников. 10 букв

ППППППППППППППППППППОООООООООООООММММММММММММООООООООООООГГГГГГГГГИИИИИИИИИТТТТТТТТТТТЕЕЕЕЕЕЕЕЕ!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

А28. Инфознайка решил сделать upgrade своего компьютера – заменить материнскую плату. Какое из следующих устройств должен заменить Инфознайка в своем компьютере?

PASKAL

1) Написать программу с циклом.
Дана переменная "n", написать программу где все значения "n" будут суммироваться пока n не будет равно 1
2) Написать программу с циклом.
Дана переменная e, нужно выводить "e" в квадрат до тех пор пока "e" не будет равно 100
--------------
program test;
var..
begin

выразить в байтах и битах 3кб.

Помогите пожалуйста)

Читайте также

ССССРРРРРРРРРРРРРРЛОООООООООООЧЧЧЧЧЧЧЧНООООООООО!!! 1. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.

Найти сумму элементов данного массива.
2. Заполнить одномерный массив, состоящий из 10 элементов, случайными числами от-15 до 35.
Найти значение максимального элемента массива.



Вы находитесь на странице вопроса "Запишите функцию для получения случайного числа x из промежутка: [0; 15) [0; 15] [-15; 15) [10; 15)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.