Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Бригаде строителей поручили уложить квадратной плиткой пол на кухне в виде шахматного узора. Но строители работали не очень слаженно, и когда весь пол

5-9 класс

уже был уложен, оказалось, что в некоторых местах плитки одинакового цвета граничат друг с другом.

По заданному замощению определите, какое минимальное число строителей могло укладывать плитку.

Входные данные

Входной файл INPUT.TXT содержит восемь строк, состоящих из восьми символов W и B – полученное замощение. Символ W обозначает плитку белого цвета, а символ B – чёрную.

Выходные данные

В выходной файл OUTPUT.TXT нужно вывести одно число - искомое число строителей.

Katena0807 16 июля 2013 г., 1:45:29 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
канок
16 июля 2013 г., 4:32:14 (10 лет назад)

var  
i, j, k : integer; 
 a : array [0..9,0..9] of char; 
procedure U(i,j:integer);  
var c : char; 
begin 
 c:=a[i,j]; a[i,j]:=' ';  
if (c='W')and(a[i+1,j]='B') then U(i+1,j);
  if (c='B')and(a[i+1,j]='W') then U(i+1,j); 
 if (c='W')and(a[i-1,j]='B') then U(i-1,j); 
 if (c='B')and(a[i-1,j]='W') then U(i-1,j); 
 if (c='W')and(a[i,j+1]='B') then U(i,j+1);  
if (c='B')and(a[i,j+1]='W') then U(i,j+1); 
 if (c='W')and(a[i,j-1]='B') then U(i,j-1); 
 if (c='B')and(a[i,j-1]='W') then U(i,j-1); 
end; 
begin  
assign(input,'input.txt');
reset(input); 
 assign(output,'output.txt');
 rewrite(output);  
for i:=1 to 8 do begin  for j:=1 to 8 do
 read(a[i,j]); 
 readln  
end;  
for i:=1 to 8 do
 begin 
 a[0,i]:=' '; a[9,i]:=' ';  a[i,0]:=' '; a[i,9]:=' '  
end; 
 k:=0; 
 for i:=1 to 8 do 
 for j:=1 to 8 do 
 if a[i,j]<>' ' then
begin 
 k:=k+1; U(i,j)  
end;  
write(k); 
 close(output) 
end. 

Ответить

Другие вопросы из категории

четыре приятеля-Женя,Костя,Дима и Вадим-делали украшения к праздннику.Кто-то делал гирлянды из золотой бумаги,кто-то красные шары,кто-то гирлянды из

серебряной бумаги,а кто -то хлопушки из золотой бумаги.Костя и Дима работали с бумагой одного цвета,Женя и Костя делала одинаковые игрушки.Кто какие украшения делал? Нужен срочно ответ до завтра!!!

1.Вставьте пропущенные слова в описании массива А, элементами которого являются целые числа. А: _________________[1..100] of ______________.

2. Опишите массив для хранения зарплаты за каждый месяц. Зарплату считать целым числом.

3.Опишите: a)Переменную В для массива, состоящую из 8 символов. b)Переменную MAS для массива, состоящего из 100 вещественных чисел. c)Переменную DAY для массива, состоящего из 30 целых чисел, причем номер первого элемента массива должен быть равен 5

.4. Пусть А : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям: a. Третий элемент массива сделать равным 5. b. Вывести на экран 7-й элемент массива. c. Ввести значение 1-го элемента массива. d. Вычислить сумму 1,2 и 3-го элементов массива.

5. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вычислить сумму всех элементов массива (используйте цикл).

6. Пусть C : array [1..10] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Вывести на экран все элементы массива.

7. Пусть А : array [1..15] of real. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Поменять местами первый и последний элементы массива.

8. Пусть В : array [1..20] of integer. Напишите операторы, соответствующие следующим действиям, при необходимости используя дополнительные переменные: Заполнить массив случайными числами из интервала [-24;37].

Читайте также

Помогитеееее

Бригаде строителей поручили уложить квадратной плиткой пол на кухне в
виде шахматного узора. Но строители работали не очень слаженно, и когда
весь пол уже был уложен, оказалось, что в некоторых местах плитки
одинакового цвета граничат друг с другом.


По заданному замощению определите, какое минимальное число строителей могло укладывать плитку.


Входные данные


Входной файл INPUT.TXT содержит восемь строк, состоящих из восьми
символов W и B – полученное замощение. Символ W обозначает плитку белого
цвета, а символ B – чёрную.


Выходные данные


В выходной файл OUTPUT.TXT нужно вывести одно число - искомое число строителей.


Примеры


№INPUT.TXTOUTPUT.TXT

Чиполлино построил домик и хочет уложить пол на кухне плиткой. Чиполлино хочет купить плитку максимально возможного размера. Сколько потребуется плиток

для укладки пола размером MxN, если резать плитку на части Чиполлино не умеет.
Входные данные: MxN - целые числа, размер пола.
Выходные данные: Целое число - кол-во плиток.

Мини-проект 2 («Kv_uravn»).

Создайте проект для расчёта корней квадратного уравнения. Продумайте названия
текстовых полей, чтобы не запутаться при программировании. Чтобы поставить
«квадрат» для икса, просто используйте ещё одну метку (Label). При нажатии на кнопку
«Рассчитать» вычисляется дискриминант, и, если он меньше нуля, то сразу
выдаётся сообщение «Корней нет» (через MsgBox), если равен нулю, то рассчитывается только значение X1, а если больше нуля – то X1 и X2. Рассчитанные значения корней должны
появиться в соответствующих текстовых полях на форме. Пример вида формы показан
на рисунке:

Var

f,f1,otladka:text;
m,n,i,j,c:integer;
ext:string;
Begin
assign(f,'CHESS.IN');
assign(f1,'CHESS.OUT');
assign(otladka,'Отладка.log');
reset(f);
rewrite(f1);
rewrite(otladka);
read(f,m,n,i,j,c);
if (m*n mod 2=0)
then
begin
writeln(otladka,'Поле делится на 2');
ext:='equal'
end
else
writeln(otladka,'Поле не делится на 2');
begin
if(c=0)
then
writeln(otladka,'Клетка (j;i) - черная');
if(j+i mod 2=0)
then
begin
writeln(otladka,'j+i делится на 2');
ext:='black'
end
else
begin
ext:='white';
writeln(otladka,'j+i не делится на 2')
end
else
begin
writeln(otladka,'Клетка (j;i) - черная');
if(j+i mod 2=0)
then
writeln(otladka,'j+i делится на 2');
ext:='white'
else
writeln(otladka,'j+i не делится на 2');
ext:='black';
end;
end;
write(f1,ext);
close(f);
close(f1);
close(otladka);
End.
Что тут не правильно? Выдает ошибку на 36 строке: Встречено 'else', а ожидалось ';', если ставлю перед else ;, пишет: Встречено 'else', а ожидался оператор

Как известно, автомобиль, изобретенный Винтиком и Шпун-тиком, работает не на бензине, а на газировке разных сортов. На одном литре лимонада он проезжает 12

0 км, на одном литре кока-колы — 100 км, на одном литре фанты — 150 км. Цена одного литра фанты в Цветочном городе — 3 монеты за литр, лимонада — 1 монета за литр, кока-колы — 2 монеты за литр. Готовясь к путешествию, Незнайка закупил 10 литров кока-колы, 5 литров лимонада и 10 литров фанты. Винтик и Шпунтик вместе купили 10 литров лимонада и 10 литров фанты. Торопыжка — 5 литров фанты, 10 — кока-колы и 10 — лимонада. Поэт Цветик — 20 литров фанты.
Построить электронную таблицу, из которой будет видно: сколько всего литров горючего купил каждый из человечков, сколько ему это стоило и какое расстояние он может проехать на этом горючем; сколько всего было куплено горючего каждого вида всеми человечками вместе, сколько это стоило и какое расстояние можно проехать на этом горючем; сколько всего горючего всех видов было куплено всеми человечками и сколько оно стоило.



Вы находитесь на странице вопроса "Бригаде строителей поручили уложить квадратной плиткой пол на кухне в виде шахматного узора. Но строители работали не очень слаженно, и когда весь пол", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.