Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана последовательность вещественных чисел а. Найти среднее арифметическое не отрицательных членов этой последовательности.

1-4 класс

89281580873 02 июля 2014 г., 14:06:59 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Helenburg
02 июля 2014 г., 16:31:36 (9 лет назад)

Var a,k,s,i:integer; Begin Readln(a); For i:=1 to a do begin Read(i); If i>=0 then begin k:=k+i; inc(s); end; End; A:=k div s; Write(a); End.

Ответить

Другие вопросы из категории

чем может отличаться приёмник информации от источника информации?

НУЖНО ВЫБРАТЬ ПРАВИЛЬНЫЙ ОТВЕТ:
1 способностью принимать информацию
2 способностью передавать информацию
3 способностью запоминать информацию
4 способностью обрабатывать информацию
5 внешним видом

Читайте также

Напишите программу, которая вводит два вещественных числа, a и b ( a < b ), и выводит через пробел 5 случайных вещественных чисел в полуинтервале [ a ,

b ) .

Входные данные
Входная строка содержит два вещественных числа a и b , разделённых пробелом. Гарантируется, что a < b .

Выходные данные
Нужно вывести в одной строке через пробел 5 случайных вещественных чисел в полуинтервале [ a , b ) с тремя знаками в дробной части.



Вы находитесь на странице вопроса "Дана последовательность вещественных чисел а. Найти среднее арифметическое не отрицательных членов этой последовательности.", категории "информатика". Данный вопрос относится к разделу "1-4" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.