Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Дан массив X(N)(N<=40) записать в массив М подряд пять первых положительных элементов массива Х, массив М расспечатать, пожалуйста сделайте блок съхему

10-11 класс

ELENA2005TIGRAN 24 окт. 2016 г., 6:23:11 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Meeoowwww
24 окт. 2016 г., 9:07:18 (7 лет назад)

uses crt;
var x,m: array [1..40] of integer;
    n,k,c:integer;
begin
     readln(n);
     c:=1;
     for k:=1 to n do
     begin
          write('x[',k,']:');
          readln(x[k]);
     end;
     k:=1;
     repeat
         if x[k]>0 then
         begin
               m[c]:=x[k];
               inc(c);
               inc(k);
         end
         else inc(k);
         until c=6;
     writeln;
     for c:=1 to 5 do
         writeln('m[',c,']:',m[c]);
end.

Ответить

Другие вопросы из категории

В матрице обнулить элементы, целая часть которых является четным числом.

Помогите это паскаль
Двумерные массивы

1)Словарный

запас племени Тумбу-Юмбу составляет 256 слов одинаковой длины. Каждая
буква алфавита несет 2 бита информации. Какова длина слова этого племени?

Читайте также

№1. Дан массив из 30-ти элементов. Каждый элемент может принимать целочисленные значения от -100 до 100. Напишите программу, которая позволит

подсчитать среднее арифметическое положительных элементов массива, которые кратны первому элементу массива. №2. Дан массив из 40 элементов. Каждый элемент может принимать целочисленные значения от 0 до 200. Напишите программу, которая позволит найти наиболее часто встречающийся элемент массива

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива

В школьной базе данных хранятся записи, содержащие информацию об учениках :<Фамилия>- 15 символов: русские буквы(первая прописная, остальные

строчные)
<Имя>- 12 символов: русские буквы(первая прописная, остальные строчные)
<Отчество>- 15 символов: русские буквы(первая прописная, остальные строчные)
<Год рождения>- числа от 1992 до 1999
Каждое поле записывается с использованием минимально возможного кол-ва бит. Определить минимальное кол-во байт, необходимое для кодирования одной записи, если буквы е и ё считаются совпадающими.

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.



Вы находитесь на странице вопроса "Дан массив X(N)(N&lt;=40) записать в массив М подряд пять первых положительных элементов массива Х, массив М расспечатать, пожалуйста сделайте блок съхему", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.