Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Рассортировать слова исходной фразы а$ по алфавиту (по заданному номеру). Исходная информация вводится с клавиатуры (QBasic)

10-11 класс

Lil999 08 нояб. 2014 г., 17:25:46 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Leskashitova
08 нояб. 2014 г., 19:36:35 (9 лет назад)

INPUT s$
k = LEN(s$) + 1
FOR i = 1 TO k
    IF MID$(s$, i, 1) = " " THEN n = n + 1 'считаем число слов
NEXT i
n = n + 1
DIM f$(n)
j = 1
FOR i = 1 TO k 'разрезаем фразу на слова и заносим их в массив f
    t$ = MID$(s$, i, 1)
    f$(j) = f$(j) + t$
    IF t$ = " " THEN j = j + 1
NEXT i
f$(n) = f$(n) + " "
FOR i = 1 TO n 'делаем сортировку массива
    FOR j = 1 TO n
        IF LEFT$(f$(i), 1) < LEFT$(f$(j), 1) THEN
            P$ = f$(i)
            f$(i) = f$(j)
            f$(j) = P$
        END IF
    NEXT j
NEXT i
FOR i = 1 TO n
    PRINT f$(i);
NEXT i

+ 0 -
Снежанна0820
08 нояб. 2014 г., 21:38:23 (9 лет назад)

На измор берут))) Ждут, пока созреете)))

+ 0 -
Alya0418
08 нояб. 2014 г., 22:15:10 (9 лет назад)

Задача опять для подружки?

+ 0 -
Gusencovalexan
09 нояб. 2014 г., 0:37:57 (9 лет назад)

даа :)

+ 0 -
Abdullaevelmin
09 нояб. 2014 г., 1:09:36 (9 лет назад)

Тут я использовал много из предыдущей задачи, они наполовину похожи. Если это для разных подружек, то надо переделать, чтобы сходство в глаза не бросалось. Ну, или пусть говорят, что совместно работали))

+ 0 -
Anya30
09 нояб. 2014 г., 3:28:45 (9 лет назад)

Аааа ничего страшного :)

Ответить

Другие вопросы из категории

Помогииииите пооожааалуйста. От этой задачи зависит оценка в четверти!!!!

Паскаль. Задано 4 числа. Первое поменять местами со 2, а 3 с 4. Используя процедуру или функцию.
Задано: 1 2 3 4
Должно получиться: 2 1 4 3

Опишите на рускком языке или в виде блок-схемы алгоритм решения обобщенного квадратного уранения: ах²+bх²+с=0 В обобщенном квадратном уравнении любой

из коэффициентов может равняться нулю(в том числе и все одновременно).

Распишите именно как сдавать,на чистовик,не что нужно делать,а именно как в задании.

Нужно решения задач по Delphi...(хотя бы одной)

1,Описати статичний масив.
Масив зчитується з текстового файлу.
Визначити:
Мінімальне значення масиву, його індекси

Задана матриця (n×m). Визначити номер рядка, середньоарифметичне елементів якої менше за середньоарифметичне попереднього рядка


2.Текстовий файл F1 має містити не менше 10 рядків.
Скопіювати з файлу F1 в файл F2 всі рядки, які не містять слова, яке починається за задану літеру. Визначте найкоротше слово у файлі F2.


Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет

Читайте также

Cоставить программу автоматического переноса слов. Исходная информация вводится с клавиатуры. (В Бейсике) Решившему скину 100 рублей на телефон , оче

нь очень надо! Я не поняла суть задания.. переноса , скорее всего, в другую строку.. Как понимаете , решите , пожааалуйста !!!!! :)))))))))

Помогите человеку с отвратительной фантазией 1. Составить задание на разработку программы линейной структуры в QBASIC

2. Составить задание на разработку программы на разветвляющиеся структуры в QBASIC

3. Составить задание на разработку программы циклической структуры в QBASIC

Нужно задание + сама программа

нарисуйте блок схему по листингу задачи.Даша Пупырышкина изучает английский язык во втором классе. Ей задали домашнее задание: переписать

английские слова, записанные строчными буквами, в тетрадь. Выполняя задание, она комментирует его. Даша произносит слово "Опять" каждый раз, когда пишет букву, которая уже встречалась в слове раньше.
Составьте программу, которая по слову определяет: сколько раз Даша произнесёт "Опять".
Примеры:
Исходное слово apple Ответ 1 раз
Исходное слово potato Ответ 2 раза
Ваша программа должна
Запросить слово;
Подсчитать сколько раз, переписывая это слово, Даша произнесёт "Опять" и вывести это число на экран.



program dasha;
var s: string;
x, l, i, y, j: byte;
begin
writeln('введите слово');
readln(s);
l := length(s);
y := 0;
for i:=1 to 1-1 do
for j:=i+1 to l do
if (s[i] = s[j]) then y := y+1;
writeln('Даша скажет опять', y, ' раз');
end.

16. Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы «AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту за первой, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево). Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

16.1. С какой буквы начинается 13-я строка?

16.2. Сколько раз буква А встречается в 10-ой строке?

16.3. Какая буква стоит на 8-ой позиции в 11-ой строке?

16.4. Сколько раз встречается буква А в первых семи строках (суммарно)?

1.Алфавит состоит из 25 букв, какое количество информации несет в себе одна буква такого алфавита?

2.Какова длина слова, если при словарном запасе в 256 слов одинаковой длины каждая буква алфавита несет в себе 2 бита информации?



Вы находитесь на странице вопроса "Рассортировать слова исходной фразы а$ по алфавиту (по заданному номеру). Исходная информация вводится с клавиатуры (QBasic)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.