Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Нарисовать квадрат со сторонами 20*20, так чтобы границы верхние и нижние(-------) были красного цвета, боковые (|||||||||||||)

5-9 класс

были красного цвета, а в середине квадрата (////////) были линии жёлтого цвета. Задача в Паскале.Заранее спасибо.Очень срочно.

Alihannurhan 03 дек. 2014 г., 18:10:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Demidtarasenko
03 дек. 2014 г., 20:34:37 (9 лет назад)

Program Test;
 Uses CRT;
 Var i,j:integer;
 a:array[1..20,1..20] of char;
 Begin
 ClrScr;
 for i:=1 to 20 do 
begin
 for j:=1 to 20 do
 begin 
if(i=1)or(i=20)then
begin 
TextColor(RED);
 if(j>1)and(j<20)then write('-'); 
end;
if(j=1)or(j=20)then begin
 TextColor(RED);
 write('|');
 end; 
if(I<>1)and(i<>20)and(j<>1)and(j<>20)then begin 
TextColor(yellow);
 write('/');
 end; 
end;
 writeln;
 end; 
End.

Ответить

Другие вопросы из категории

сделать таблицу в exel: собираясь на пляж,вселые человечки решили запастись питьем.Незнайка взял с собой 2 литра кваса и литр газировки,пончик-литр

газировки и 3 литра малинового сиропа,Винтик и Шпунтик вместе взяли 3 литра кваса и 2 литра газировки,Торопыжка-3 литра газировки,доктро Пилюлькин 1 литр кваса и литр касторки. 1 литр квасастоит 1 монету,1 литр газировки 3 монеты,1 литр касторки-2 монеты,1 литр сиропа-6 монет сколько всего напитков взял с собой человечек и сколько ему это стоило;какое кол-во напитка каждого вида взяли все человечки вместе и сколько им это стоило;сколько всего было взято жидкости и сколько потрачено денег всеми человечками вместе? ___________________ [email protected]

цепочка бег - шаг ( 7 слов с промежутке)

ПОМОГИТЕ(

Вывести на экран все четные числа, начиная с числа N и заканчивая числом M

Подсказска:
i это текущие значения
N до M значит от начала до конца , начальное число N, концовое M
mod использоватсья надо, поомгите пожалуйста, отблагодарю

год cоздание первого компьютера

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Определить, можно ли квадрат со стороной a поместить в окружность заданного радиуса R?

Входные данные:
Во входном потоке задано два вещественных числа - радиус окружности R и сторона квадрата a. Значение всех исходных величин не превышает 30000.

Выходные данные:
В выходной поток вывести 'YES' или 'NO'.

Пример входного файла
2 1
Пример выходного файла
YES



Вы находитесь на странице вопроса "Нарисовать квадрат со сторонами 20*20, так чтобы границы верхние и нижние(-------) были красного цвета, боковые (|||||||||||||)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.