Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

найти максимальный по значению элемент матрицы x (n,m) (n<=10,m<=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое

10-11 класс

положительных элементов матрицы. полученную матрицу x и среднее арифмитическое распечатать

Юля210781 17 июня 2014 г., 4:44:22 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Mazov2013
17 июня 2014 г., 6:05:45 (9 лет назад)

program new;
var max.summ,i,j,kol:integer; x:array[1..10,1..15] of integer;sr:real;
begin
randomize;
for i=1 to 10 do
begin
for j=1 to 15 do
begin
x[i,j]:=random(51)-25;   {не знаю как у тебя заполняется матрица так что заполнил} 
end;                            {его сам отрицательными и положительными от-25 до 25} 
end;
max:=x[1,1];
summ:=0;
kol:=0;
for i=1 to 10 do
begin
for i=1 to 15 do
begin
if x[i,j]>max then max:=x[i,j]
if x[i,j]>0 then
begin
summ:=summ+x[i,j];
kol:=kol+1;
end;
end;
end;
for i=1 to 10 do
begin
for i=1 to 15 do
begin 
if a[i,j]:=max then a[i,j]:=a[i,j]*2
end;
end;
for i=1 to 10 do
begin
for i=1 to 15 do
begin
write(a[i,j]:3)
end;
writeln;
end;
sr:=summ/kol;
writeln('Среднее арифетическое равно',sr:6);
end.  

Ответить

Другие вопросы из категории

помогите пожалуйста №6!!!
HELP!HELP!

Составить программу по нахождению минимального элемента массива и определить его местонахождение в массиве.

Читайте также

Помогите пожалуйста)) очень-очень срочно(( С# Получить элементы массива А по формуле .... Вычисленый массив вывести на печать.

Найти максимальный по модулю элемент массива А.

Массив я вычислил, а остальное не получается(

using System;

using System.Collections.Generic;

using System.Linq;

using System.Text;

namespace ConsoleApplication27

{

class Program

{

static void Main(string[] args)

{

int n = 30;

double[] a = new double[30];

for (int i = 0; i <= 20; i++)

{

a[i] = Math.Sqrt(i ^ 2 + 1) - Math.Sin(i / n);

Console.WriteLine("a(" + i + ")=" + a[i]);

}Console.ReadKey();

}

}

}




Вы находитесь на странице вопроса "найти максимальный по значению элемент матрицы x (n,m) (n&lt;=10,m&lt;=15) и увеличить его в 2 раза. после этого вычислить среднее арифмитическое", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.