Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Ввести два слова. Определить, состоят ли они из одного и того же набора символов или нет.

5-9 класс

Zvezday2009 07 мая 2013 г., 19:04:47 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kamilasolnyshk
07 мая 2013 г., 20:08:38 (11 лет назад)

var
    s, s2 : String;
    Check : Boolean;
    i : Integer;
begin

    Write('Введите первое слово: ');
    ReadLn(s);


    Write('Введите второе слово: ');
    ReadLn(s2);

    if Length(s) <> Length(s2) then
    begin
        Writeln('No');
        exit;
    end;

    Check := True;

   for i := 1 to Length(s) do
   if pos(s[i], s2) <> 0 then
      Delete(s, pos(s[i], s2), 1)
   else Check := False;

   If Check then
      Writeln('Yes')
   else
      Writeln('No');

   Readln;
end.

Ответить

Другие вопросы из категории

помогите плиз:3

заранее спасибо
Подсчитайте оъем данных , передаваемых в секунду от видеопамяти к монитору р режиме 1024 х 768 пикселей с глубиной ццвета 16 битов и частотой обновлений экрана 75Гц .

Читайте также

№19. Даны стороны треугольника. Определить является ли этот треугольник: а) равносторонним б) равнобедренным в) прямоугольным.

№20. Даны величины углов треугольника. Определить является ли это треугольник:

а) остроугольным

б) тупоугольным

в) прямоугольным

г) равносторонним

д) равнобедренным.

№21. Определить, какая из двух точек - M1(x1,y1) или M2(x2,y2) - расположена ближе к началу координат. Вывести на экран дисплея координаты этой точки.

№22. Даны действительные числа a, b, c, x, y. Выяснить, пройдет ли кирпич с ребрами a,b,c в прямоугольное отверстие со сторонами x и y. Просовывать кирпич в отверстие разрешается только так, чтобы каждое из его ребер было параллельно или перпендикулярно каждой из сторон отверстия.

№23. Написать программу, которая печатает True или False в зависимости от того, выполняются или нет заданные условия:

а) квадрат заданного трехзначного числа равен кубу суммы цифр этого числа;

б) сумма двух первых цифр заданного четырехзначного числа равна сумме двух его последних цифр;

в) среди цифр заданного трехзначного числа есть одинаковые;

г) среди первых трех цифр из дробной части заданного положительного вещественного числа есть цифра 0.

Даны 3 числа a,b,c

определить: являются ли они углами прямоугольного треугольника



Вы находитесь на странице вопроса "Ввести два слова. Определить, состоят ли они из одного и того же набора символов или нет.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.