Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Вводится слово из 4 букв. Определить, есть ли в нем одинаковые буквы.

5-9 класс

В программе паскаль !! Срочно !!!!

Dasya551 25 нояб. 2013 г., 6:00:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tati00
25 нояб. 2013 г., 8:17:42 (10 лет назад)

var s: string;
i, j, k: integer;
a: array [1..256] of char;
begin
readln(s);
for i:= 1 to length(s) do begin
    for j:= 1 to k do
        if a[j] = s[i] then begin
           writeln('Есть');
           exit;
           end;
    a[i]:= s[i];
    inc(k);
    end;
writeln('Нет');
end.
Попрошу отметить, как лучшее решение

Ответить

Другие вопросы из категории

Найти сумму элементов последовательности с точностью 0,001:

S=1 + 2/(2*3) - 4/(3*9) + 6/(5*27) - 8/(8*81) + 10/(13*243) - ...

Программист Сережа написал программу по проверке сбойных секторов на диске. Тестируя программу, Сережа обнаружил, что проверено 25952 сектора. Ровно

через 2 секунды на счетчике опять появилось число, которое читается одинаково в обоих направлениях и является самым близким к 25952. Сколько секторов проверяется за секунду?

Читайте также

.Вводится слово из 4 букв. Определить, есть ли в нем одинаковые буквы. .......

В программе паскаль !!!Срочно !!

1. Дано натуральное число n. Определить есть ли в нем цифра x. (x, n - вводятся с клавиатуры)

2. Напишите программу, которая вводит последовательность целых ненулевых чисел, признак окончания ввода - число 0. Выясните есть ли в ней хотя бы одна пара одинаковых "соседних" чисел. СРОЧНО!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Помогите, пожалуйста

Дано трехзначное число. Нужно определить есть ли в нем одинаковые цифры Паскаль. Начало сделала, а вот ,что дальше не знаю
program dzkan;
var x,a,b,c:integer;
begin
writeln(Введите трехзначное число');
readln(x);
a:=x div 100;
b:=x mod 100 div 10;
c:=x mod 10;




Вы находитесь на странице вопроса "Вводится слово из 4 букв. Определить, есть ли в нем одинаковые буквы.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.