Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти среднее арифметическое всех положительных целых чисел от a до b (b>=a) Если таких чисел нет то вывести сообщение "Таких чисел нет"

5-9 класс

Программа на Паскале (net или abc)

Tetenov98 05 окт. 2014 г., 12:56:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kikusik
05 окт. 2014 г., 14:47:03 (9 лет назад)

Program Task;
Const a = 5;
b = 10;
Var i, c, d: Integer;
Begin
If a > b Then
WriteLn('Ошибка')
Else
Begin
For i := a To b Do
If i > 0 Then
Begin
c := c + i;
d := d + 1;
End;
If d > 0 Then
WriteLn('Результат: ', (c / d):5:2)
Else
WriteLn('Таких чисел нет');
End;
End.

Ответить

Читайте также

Даны два целых числа А и В (А < В) . Найти произведение всех целых чисел от А до В включительно.

Входные данные: ввести два целых числа А,В (1 <=А,В<=10).
Входные данные: вывести произведение всех целых чисел от А до В включительно.

составть программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:

а) среднее арифметическое нечетных чисел
б) сумму чисел, не превышающих 10
в сумму чисел, кратных 3
На экран выводятся исходные значения и результаты вычислений
Плиз помогите, завтра здать нужно((

1)Вывести на экран квадраты и кубы нечётных целых чисел от 9 до 1.

2)Даны натуральные числа от 1 до 150. Найти сумму тех из них, которые делятся на 5 или на 7.
3)Напечатать те из чисел от 10 до 50, которые делятся на 4, но не делятся на 6
4)Найти произведение нечетных чисел от 10 до 50, кратных 13
кто может сделать в Паскале или просто решить?

1.Дан массив целых чисел, найти среднее арифметическое всех элементов массива.

2. Дан массив целых чисел,найти количество отрицательных элементов массива.
3. Дан массив целых чисел,найти количество чётных чисел в массиве.

1)Составить программу нахождения суммы квадратов чисел от 25 до 125.

2) составить программу нахождения чисел от 10 до 99 сумма квадратов которых кратна 13 (mod=0)
3) найти сумму всех целых нечетных чисел меньших 100
4) найти сумму чисел в диапазоне от A до B кратных четырём. Числа А и В вводятся с клавы.
5) Найти все натуральный делители натурального числа n



Вы находитесь на странице вопроса "Найти среднее арифметическое всех положительных целых чисел от a до b (b&gt;=a) Если таких чисел нет то вывести сообщение "Таких чисел нет"", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.