Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

составить программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превышает 100 (каждое число с но

10-11 класс

вой строки), и если среди них есть неотрицательное число, то выводит это число или выводит сумму всех отрицательных введенных чисел в остальных случаях.

Fortnet 04 сент. 2016 г., 11:44:00 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lybavaselihova
04 сент. 2016 г., 13:44:24 (7 лет назад)

Program n1;
Uses CRT;
Var a,b,c: integer;
begin
ClrScr;
Writeln('Vvedite chisla');
Readln(a,b,c);
If(a<0)and(b<0)and(c<0) then writeln('Summa = ',a+b+c)
else
if (a>0) then writeln('polozhitelnoe chislo ',a) else
if (b>0) then writeln('polozhitelnoe chislo ',b) else
if (c>0) then writeln('polozhitelnoe chislo ',c);
readln
end.

Ответить

Читайте также

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.

10. Составьте

программу, которая вводит
с клавиатуры три
целых числа: a, b, c (каждое
число с новой
строки) и выводит
на экран максимальное
из них. Ничего
кроме этого числа,
программа выводить не
должна.



Вы находитесь на странице вопроса "составить программу, которая вводит с клавиатуры три различных целых числа, каждое из которых по абсолютной величине не превышает 100 (каждое число с но", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.